summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Woerner <twoerner@redhat.com>2012-11-02 12:48:53 (GMT)
committerThomas Woerner <twoerner@redhat.com>2012-11-02 12:48:53 (GMT)
commitdd96cc55858e1fbd66f07a9e383c49bd4e79c701 (patch)
tree20558736b84f0e131297d572fe6c3737d7a94c34
parentfa59546b65e1271163622e6675181ed97e917265 (diff)
downloadiptables-dd96cc55858e1fbd66f07a9e383c49bd4e79c701.zip
iptables-dd96cc55858e1fbd66f07a9e383c49bd4e79c701.tar.gz
iptables-dd96cc55858e1fbd66f07a9e383c49bd4e79c701.tar.xz
- fixed missing services for update of pre F-18 installations (rhbz#867960)
- provide and obsolete old main package in services sub package - provide and obsolete old ipv6 sub package (pre F-17) in services sub package
-rw-r--r--iptables.spec16
1 files changed, 12 insertions, 4 deletions
diff --git a/iptables.spec b/iptables.spec
index a6debf1..4594071 100644
--- a/iptables.spec
+++ b/iptables.spec
@@ -25,7 +25,7 @@
Name: iptables
Summary: Tools for managing Linux kernel packet filtering capabilities
Version: 1.4.16.2
-Release: 3%{?dist}
+Release: 4%{?dist}
Source: http://www.netfilter.org/projects/iptables/files/%{name}-%{version}.tar.bz2
Source1: iptables.init
Source2: iptables-config
@@ -43,9 +43,6 @@ Conflicts: kernel < 2.4.20
%if %{with systemd}
BuildRequires: systemd-units
%endif
-# provide also ipv6 sub package
-Provides: %{name}-ipv6 = %{version}-%{release}
-Obsoletes: %{name}-ipv6 < %{version}-%{release}
%if %{_lib} == lib64
Provides: libxtables.so.7()(64bit)
@@ -86,6 +83,12 @@ Conflicts: filesystem < 3
Requires(post): chkconfig
Requires(preun): chkconfig
%endif
+# provide and obsolete old main package
+Provides: %{name} = 1.4.16.1
+Obsoletes: %{name} <= 1.4.16.1
+# provide and obsolte ipv6 sub package
+Provides: %{name}-ipv6 = 1.4.11.1
+Obsoletes: %{name}-ipv6 <= 1.4.11.1
%description services
iptables services for IPv4 and IPv6
@@ -292,6 +295,11 @@ fi
%changelog
+* Fri Nov 2 2012 Thomas Woerner <twoerner@redhat.com> 1.4.16.2-4
+- fixed missing services for update of pre F-18 installations (rhbz#867960)
+ - provide and obsolete old main package in services sub package
+ - provide and obsolete old ipv6 sub package (pre F-17) in services sub package
+
* Sun Oct 14 2012 Dan HorĂ¡k <dan[at]dany.cz> 1.4.16.2-3
- fix the compat provides for all 64-bit arches