Blob Blame History Raw
# Generated by go2rpm
%if 0%{?__isa_bits} != 32
%bcond_without check
%else
%bcond_with check
%endif

# https://github.com/go-yaml/yaml
%global goipath         gopkg.in/yaml.v2
%global forgeurl        https://github.com/go-yaml/yaml
Version:                2.4.0

%gometa

%global goaltipaths     gopkg.in/v2/yaml

%global common_description %{expand:
The yaml package enables Go programs to comfortably encode and decode YAML
values. It was developed within Canonical as part of the juju project, and is
based on a pure Go port of the well-known libyaml C library to parse and
generate YAML data quickly and reliably.

The yaml package supports most of YAML 1.1 and 1.2, including support for
anchors, tags, map merging, etc. Multi-document unmarshalling is not yet
implemented, and base-60 floats from YAML 1.1 are purposefully not supported
since they're a poor design and are gone in YAML 1.2.}

%global golicenses      LICENSE LICENSE.libyaml NOTICE
%global godocs          README.md

Name:           %{goname}
Release:        %autorelease
Summary:        Yaml support for the Go language

License:        Apache-2.0 and MIT
URL:            %{gourl}
Source0:        %{gosource}
%if %{with check}
BuildRequires:  golang(gopkg.in/check.v1)
%endif

%description
%{common_description}

%gopkg

%prep
%goprep
%autopatch -p1


%install
%gopkginstall

%if %{with check}
%check
%gocheck
%endif

%gopkgfiles

%changelog
%autochangelog