Blob Blame History Raw
# Generated by go2rpm
%bcond_without check

# https://github.com/uber-go/multierr
%global goipath         go.uber.org/multierr
%global forgeurl        https://github.com/uber-go/multierr
Version:                1.6.0

%gometa

%global common_description %{expand:
Package Multierr allows combining one or more errors together.}

%global golicenses      LICENSE.txt
%global godocs          CHANGELOG.md README.md

Name:           %{goname}
Release:        %autorelease
Summary:        Combine one or more go errors together

License:        MIT
URL:            %{gourl}
Source0:        %{gosource}

BuildRequires:  golang(go.uber.org/atomic)

%if %{with check}
# Tests
BuildRequires:  golang(github.com/stretchr/testify/assert)
BuildRequires:  golang(github.com/stretchr/testify/require)
%endif

%description
%{common_description}

%gopkg

%prep
%goprep

%install
%gopkginstall

%if %{with check}
%check
%gocheck
%endif

%gopkgfiles

%changelog
%autochangelog