Blob Blame History Raw
# Filtering of private libraries
%global privlibs libbrowsercomps
%global privlibs %{privlibs}|libclearkey
%global privlibs %{privlibs}|libdbusservice
%global privlibs %{privlibs}|libmozalloc
%global privlibs %{privlibs}|libmozgnome
%global privlibs %{privlibs}|liblgpllibs

%global __provides_exclude ^(%{privlibs})\\.so
%global __requires_exclude ^(%{privlibs})\\.so
#

##Active/Deactive language files handling
%global build_langpacks  0

##Define installation directories
%global icecatappdir    %{_libdir}/%{name}-%{version}
%global icecat_ver      %{name}-%{version}
%global icecat_devel    %{name}-devel-%{version}

##Define language files directory
%global langpackdir     %{icecatappdir}/langpacks

##Define default bookmarks
%global default_bookmarks_file %{_datadir}/bookmarks/default-bookmarks.html

%global toolkit_gtk3      1

# Builds for debugging
%global debug_build       0

## Pulseaudio
%bcond_without pulseaudio
#

Name:    icecat
Version: 45.7.0
Release: 4%{?dist}
Summary: GNU version of Firefox browser
Group:   Applications/Internet

## Tri-licensing scheme for Gnuzilla/IceCat in parentheses, and licenses for the extensions included
License: (MPLv1.1 or GPLv2+ or LGPLv2+) and GPLv3+ and GPLv2+ and Public Domain and MIT and BSD and ISC and ASL 2.0 and MPLv2.0
URL:     http://www.gnu.org/software/gnuzilla/
Source0: http://jenkins.trisquel.info/icecat/icecat-%{version}-gnu1.tar.bz2
Source1: %{name}.desktop
Source2: %{name}.png
Source3: %{name}-mozconfig-common

%if %{build_langpacks}
##Language files downloaded by source7 script
Source4:  %{name}-%{version}-langpacks.tar.gz
Source7:  %{name}-lang_download.sh
%endif

##All license files
##Download from http://www.gnu.org/licenses
##Download from http://www.mozilla.org/MPL/1.1/index.txt
##Download from https://www.mozilla.org/MPL/2.0/index.txt
Source5: %{name}-COPYING-licensefiles.tar.gz

##manpage file
Source6: %{name}.1

# Fix headers for GCC-6
Patch0: %{name}-gcc-6.0.patch

##Using system Python Virtualenv
Patch1: %{name}-virtualenv.patch

##Prevent HTTPS-everywhere's installation
Patch2: %{name}-noHTTP-RP.patch

# Remove Wno-format flag
Patch3: %{name}-build-werror.patch

##Bug https://bugzilla.mozilla.org/show_bug.cgi?id=1093069
Patch4: %{name}-system_nss_header.patch

# Fix for ARM builds
Patch5: %{name}-build-arm.patch

# Remove unrecognized flags
Patch6: %{name}-remove_unrecognized_flags.patch

# https://bugzilla.redhat.com/show_bug.cgi?id=814879#c3
Patch7: %{name}-xulrunner-24.0-jemalloc-ppc.patch

# https://bugzilla.mozilla.org/show_bug.cgi?id=1013882
Patch8: %{name}-debug_build.patch

# https://bug623317.bugzilla.mozilla.org/show_bug.cgi?id=1246854
Patch9: %{name}_remove_unnecessary_warns.patch

Patch21: firefox-ppc64le.patch

# Fedora specific patches
Patch223: rhbz-1291190-appchooser-crash.patch

# Upstream patches
Patch304: mozilla-1253216.patch
# patch 306 is obsoleted by patch 307
#Patch306: mozilla-1245076-1.patch
Patch307: mozilla-1269171.patch

BuildRequires:  alsa-lib-devel
BuildRequires:  bzip2-devel
BuildRequires:  cairo-devel
BuildRequires:  ccache
BuildRequires:  dbus-devel
BuildRequires:  dbus-glib-devel
BuildRequires:  dconf
BuildRequires:  desktop-file-utils
BuildRequires:  freetype-devel
BuildRequires:  gdk-pixbuf2
BuildRequires:  glib2-devel
BuildRequires:  pkgconfig(gtk+-2.0)
%if %{toolkit_gtk3}
BuildRequires:  pkgconfig(gtk+-3.0)
%endif
BuildRequires:  gstreamer1-devel
BuildRequires:  gstreamer1-plugins-base-devel
BuildRequires:  gstreamer-devel
BuildRequires:  gstreamer-plugins-base-devel
BuildRequires:  hunspell-devel
BuildRequires:  ImageMagick
BuildRequires:  java-1.8.0-openjdk-headless
BuildRequires:  intltool
BuildRequires:  libappstream-glib
BuildRequires:  libevent-devel
BuildRequires:  libicu-devel
BuildRequires:  libIDL-devel
BuildRequires:  libjpeg-turbo-devel
BuildRequires:  libjpeg-devel
BuildRequires:  libX11-devel
BuildRequires:  libXt-devel
BuildRequires:  libXrender-devel
BuildRequires:  libyuv-devel
BuildRequires:  libXinerama-devel
BuildRequires:  libffi-devel
BuildRequires:  libnotify-devel
BuildRequires:  libpng-devel
BuildRequires:  libvpx-devel
BuildRequires:  libzip-devel
BuildRequires:  mesa-libGL-devel
BuildRequires:  nspr-devel
BuildRequires:  nss-devel, nss-static
BuildRequires:  nss-util-devel, nss-tools
BuildRequires:  openjpeg-devel
BuildRequires:  pango-devel
BuildRequires:  python2-devel
BuildRequires:  python-blessings
BuildRequires:  python-mock
BuildRequires:  python-ply
BuildRequires:  python-psutil
BuildRequires:  python-setuptools
BuildRequires:  python-virtualenv
BuildRequires:  python-which
BuildRequires:  pkgconfig(gconf-2.0)
BuildRequires:  pkgconfig(xrender)
BuildRequires:  pkgconfig(libstartup-notification-1.0)
BuildRequires:  pkgconfig(dri)
BuildRequires:  pkgconfig(libcurl)
%if %{with pulseaudio}
BuildRequires:  pulseaudio-libs-devel
%endif
BuildRequires:  sqlite-devel
BuildRequires:  system-bookmarks
BuildRequires:  yasm-devel

Requires:       dconf
Requires:       mozilla-filesystem
Requires:       nspr
Requires:       nss
Requires:       system-bookmarks
Requires:       sqlite

Provides:       webclient
Provides:       bundled(xul) = 45

%description
GNUZilla Icecat is a fully-free fork of Mozilla Firefox ESR.
Extensions included to this version of IceCat:
 
 * LibreJS
   GNU LibreJS aims to address the JavaScript problem described in Richard
   Stallman's article The JavaScript Trap.
 
 * SpyBlock
   Blocks privacy trackers while in normal browsing mode, and all third party
   requests when in private browsing mode. Based on Adblock Plus.
 
 * AboutIceCat
   Adds a custom "about:icecat" homepage with links to information about the
   free software and privacy features in IceCat, and check-boxes to enable
   and disable the ones more prone to break websites.
 
 * HTML5-video-everywhere
   Uses the native video player to play embedded videos from different sources

 * Fingerprinting countermeasures: Fingerprinting is a series of techniques
   allowing to uniquely identify a browser based on specific characterisics of
   that particular instance (like what fonts are available in that machine).
   Unlike cookies the user cannot opt-out of being tracked this way,
   so the browser has to avoid giving away that kind of hints.

%prep
%setup -q -n %{name}-%{version}

mkdir -p browser/branding/unofficial
touch browser/branding/unofficial/moz.build

##Remove spurious executable permissions
for i in `find . -perm /111 -type f \( -name "*.h" -o -name "*.c" \)`; do
chmod a-x $i
done

##Copy license files
tar -xf %{SOURCE5}

%patch0 -p0
%patch1 -p0
%patch2 -p0
%patch3 -p0
%patch4 -p0

%ifarch %{arm}
%patch5 -p0
%endif

%patch6 -p0
%patch7 -p0 -b .jemalloc-ppc

%if %{?debug_build}
%patch8 -p1
%endif

%patch9 -p1

%patch21 -p2 -b .ppc64le

%patch304 -p2 -b .1253216
%patch223 -p1 -b .appchooser-crash

%patch307 -p1 -b .1269171

##Remove default configuration and copy the customized one
cp -p %{SOURCE3} mozconfig-common

##Options for ARM
%ifarch armv7hl
echo "ac_add_options --with-arch=armv7-a" >> mozconfig-common
echo "ac_add_options --with-float-abi=hard" >> mozconfig-common
echo "ac_add_options --with-fpu=vfpv3-d16" >> mozconfig-common
echo "ac_add_options --disable-debug-symbols" >> mozconfig-common
%endif
%ifarch armv7hnl
echo "ac_add_options --with-arch=armv7-a" >> mozconfig-common
echo "ac_add_options --with-float-abi=hard" >> mozconfig-common
echo "ac_add_options --with-fpu=neon" >> mozconfig-common
echo "ac_add_options --disable-debug-symbols" >> mozconfig-common
%endif
%ifarch armv5tel
echo "ac_add_options --with-arch=armv5te" >> mozconfig-common
echo "ac_add_options --with-float-abi=soft" >> mozconfig-common
echo "ac_add_options --disable-debug-symbols" >> mozconfig-common
%endif

%ifnarch %{ix86} x86_64 armv7hl armv7hnl
echo "ac_add_options --disable-methodjit" >> mozconfig-common
echo "ac_add_options --disable-monoic" >> mozconfig-common
echo "ac_add_options --disable-polyic" >> mozconfig-common
echo "ac_add_options --disable-tracejit" >> mozconfig-common
%endif

%ifnarch %{ix86} x86_64
echo "ac_add_options --disable-webrtc" >> mozconfig-common
%endif

%ifarch %{arm}
echo "ac_add_options --enable-png-arm-neon-support=check" >> mozconfig-common
%endif

%ifarch aarch64
echo "ac_add_options --enable-png-arm-neon-support=no" >> mozconfig-common
%endif

%if %{toolkit_gtk3}
echo "ac_add_options --enable-default-toolkit=cairo-gtk3" >> mozconfig-common
%else
echo "ac_add_options --enable-default-toolkit=cairo-gtk2" >> mozconfig-common
%endif

%if %{with pulseaudio}
echo "ac_add_options --enable-pulseaudio" >> mozconfig-common
%endif

%ifarch s390 s390x
echo "ac_add_options --disable-jemalloc" >> mozconfig-common
%else
echo "ac_add_options --enable-jemalloc" >> mozconfig-common
%endif

%build

%if !%{?debug_build}
SETOPT_FLAGS=$(echo "$RPM_OPT_FLAGS" | sed -e 's/-Wall//g' -e 's/-fexceptions//g')
MOZ_OPT_FLAGS="$SETOPT_FLAGS -Wformat-security -Wformat -Werror=format-security"
%endif

%ifarch s390 s390x
MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | sed -e 's/-g/-g1/' )
%endif
%ifarch %{arm} && !%{?debug_build}
MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | sed -e 's/-O2/-O0/' )
%endif
# Workaround for #1332926
%ifnarch %{arm} && !%{?debug_build}
MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | sed -e 's/-O2/-O1/' )
%endif
%if %{?debug_build}
MOZ_OPT_FLAGS='-O0 -g'
%endif

# Disable null pointer gcc6 optimization in gcc6 (rhbz#1328045)
%if 0%{?fedora} < 26
MOZ_OPT_FLAGS="$MOZ_OPT_FLAGS -fPIC -fno-delete-null-pointer-checks $RPM_LD_FLAGS -Wl,-z,now"
%else
MOZ_OPT_FLAGS="$MOZ_OPT_FLAGS -fPIC $RPM_LD_FLAGS -Wl,-z,now"
%endif

%ifarch s390 %{arm} %{power64} aarch64
MOZ_LINK_FLAGS="-Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
%endif

export _WARNINGS_CFLAGS=" -Wno-unused -Wdeclaration-after-statement -Wempty-body -Wpointer-to-int-cast -Wtype-limits"
export _WARNINGS_CXXFLAGS=" -Wno-unused -Wempty-body -Wtype-limits"
export _ADDED_CXXFLAGS=""
mkdir -p %{name}-objdir && pushd %{name}-objdir
../configure \
 --prefix=%{_prefix} \
 --libdir=%{_libdir} \
 --includedir=%{_includedir} \
 --datadir=%{_datadir} \
 --mandir=%{_mandir} \
 --with-system-nspr \
 --with-system-nss \
 --with-system-nspr-prefix=%{_bindir} \
 --with-system-nspr-exec-prefix=%{_bindir} \
 --with-system-nss-prefix=%{_bindir} \
 --with-system-nss-exec-prefix=%{_bindir} \
 --with-system-icu \
 --enable-system-ffi \
%if %{toolkit_gtk3}
 --enable-system-cairo \
%endif
 --enable-gstreamer=1.0 \
 --enable-system-hunspell \
 --enable-system-pixman \
 --enable-system-sqlite \
 --with-system-zlib \
 --with-system-bz2 \
 --with-system-libevent \
 --enable-llvm-hacks \
 --with-ccache \
 --with-system-libvpx \
%ifnarch %{ix86} x86_64
 --disable-webrtc \
%endif
 --disable-libjpeg-turbo \
 --with-system-jpeg=%{_bindir} \
 --disable-crashreporter \
%if %{?debug_build}
 --enable-debug \
 --enable-debug-symbols \
%else
 --disable-debug \
 --disable-debug-symbols \
%endif
 --disable-strip \
 --disable-install-strip \
 --disable-tests \
 --with-branding=browser/branding/official \
%ifarch %{arm}
 --disable-optimize
%else
 --enable-optimize="$MOZ_OPT_FLAGS"
%endif

# On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
# however builds tend to fail on other arches when building in parallel.
%ifarch %{ix86} x86_64 %{power64}
[ -z "$RPM_BUILD_NCPUS" ] && \
     RPM_BUILD_NCPUS="`%{_bindir}/getconf _NPROCESSORS_ONLN`"
[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
[ "$RPM_BUILD_NCPUS" -ge 8 ] && MOZ_SMP_FLAGS=-j8
%else
MOZ_SMP_FLAGS=-j1
%endif

export CFLAGS=$MOZ_OPT_FLAGS
export CXXFLAGS="$MOZ_OPT_FLAGS"
export LDFLAGS=$MOZ_LINK_FLAGS
export _WARNINGS_CFLAGS=" -Wno-unused -Wdeclaration-after-statement -Wempty-body -Wpointer-to-int-cast -Wtype-limits"
export _WARNINGS_CXXFLAGS=" -Wno-unused -Wempty-body -Wtype-limits"
export _ADDED_CXXFLAGS=""

export MOZCONFIG=mozconfig-common
%ifarch %{arm} && %{?debug_build}
make -j2
%endif
%if !%{?debug_build}
make $MOZ_SMP_FLAGS
%endif
popd

%install
make -C %{name}-objdir install DESTDIR=$RPM_BUILD_ROOT

##Resize IceCat icon
for i in 16 22 24 32 36 48 64 72 96 128 256 ; do
  mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${i}x${i}/apps
  convert -geometry ${i} %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${i}x${i}/apps/icecat.png
done

##desktop file installation
mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
install -pm 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/applications

##Install man page
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
install -p -m 644 %{SOURCE6} $RPM_BUILD_ROOT%{_mandir}/man1

##Make sure locale works for langpacks
cat > %{name}-objdir/dist/bin/browser/defaults/preferences/icecat-l10n.js << EOF
pref("general.useragent.locale", "chrome://global/locale/intl.properties");
EOF

##set up our default bookmarks
cp -p %{default_bookmarks_file} %{name}-objdir/dist/bin/browser/defaults/profile/bookmarks.html

##Extract langpacks, make any mods needed, repack the langpack, and install it.
%if %{build_langpacks}
echo > %{name}.lang
mkdir -p $RPM_BUILD_ROOT%{langpackdir}
tar xf %{SOURCE4}
 for langpack in `ls langpacks/*.xpi`; do
  language=`basename $langpack .xpi`
  extensionID=langpack-$language@icecat.mozilla.org
  mkdir -p $extensionID
  unzip -qq $langpack -d $extensionID
  find $extensionID -type f | xargs chmod 644

  cd $extensionID
  zip -qq -r9mX ../${extensionID}.xpi *
  cd -

  install -p -m 644 ${extensionID}.xpi $RPM_BUILD_ROOT%{langpackdir}
  language=`echo $language | sed -e 's/-/_/g'`
  echo "%%lang($language) %{langpackdir}/${extensionID}.xpi" >> %{name}.lang
 done
rm -rf %{name}-langpacks

##Install langpack workaround (see #707100, #821169)
function create_default_langpack() {
language_long=$1
language_short=$2
cd $RPM_BUILD_ROOT%{langpackdir}
ln -s langpack-$language_long@icecat.mozilla.org.xpi langpack-$language_short@icecat.mozilla.org.xpi
cd -
echo "%%lang($language_short) %{langpackdir}/langpack-$language_short@icecat.mozilla.org.xpi" >> %{name}.lang
}
%endif

##Same files symlinked
ln -sf  %{_libdir}/%{icecat_ver}/libmozalloc.so $RPM_BUILD_ROOT%{_libdir}/%{icecat_devel}/sdk/lib/libmozalloc.so
ln -sf  %{_libdir}/%{icecat_ver}/libxul.so $RPM_BUILD_ROOT%{_libdir}/%{icecat_devel}/sdk/lib/libxul.so
ln -sf  %{_libdir}/%{icecat_ver}/icecat-bin $RPM_BUILD_ROOT%{_libdir}/%{icecat_ver}/icecat

##Fix executable permissions of some files
for i in `find $RPM_BUILD_ROOT -type f \( -name "*.sh" -o -name "*.py" -o -name "xpcshell" \)`; do
chmod a+x $i
done

mkdir -p $RPM_BUILD_ROOT%{_datadir}/appdata
cat > $RPM_BUILD_ROOT%{_datadir}/appdata/icecat.appdata.xml <<EOF
<?xml version="1.0" encoding="UTF-8"?>
<component type="desktop">
  <id type="desktop">icecat.desktop</id>
  <metadata_license>CC0-1.0</metadata_license>
  <summary>GNU version of Firefox browser</summary>
  <name>icecat</name>
  <project_license>(MPL-1.1 or GPL-2.0+ or LGPL-2.0+) and GPL-3.0+ and GPL-2.0+ and Public Domain and MIT and BSD and ISC and ASL-2.0 and MPL-2.0</project_license>
  <categories>
   <category>Internet</category>
   <category>Web Browser</category>
  </categories>
  <description>
    <p>
      GNUzilla is the GNU version of the Mozilla suite, and GNU IceCat is the GNU version of the Firefox ESR browser.
    </p>  
    <p>
       Its main advantage is an ethical one: it is entirely free software:
       while the Firefox source code from the Mozilla project is free software,
       they distribute and recommend non-free software as plug-ins and addons.
       Also their trademark license restricts distribution in several ways incompatible with freedom 0.
    </p>
    <p>
       Extensions included to this version of IceCat:
        - LibreJS
          GNU LibreJS aims to address the JavaScript problem described in Richard
          Stallman's article The JavaScript Trap.
        - SpyBlock
          Blocks privacy trackers while in normal browsing mode, and all third party
          requests when in private browsing mode. Based on Adblock Plus.
        - AboutIceCat
          Adds a custom "about:icecat" homepage with links to information about the
          free software and privacy features in IceCat, and check-boxes to enable
          and disable the ones more prone to break websites.
        - HTML5-video-everywhere
          Uses the native video player to play embedded videos from different sources
        - Fingerprinting countermeasures: Fingerprinting is a series of techniques
          allowing to uniquely identify a browser based on specific characterisics of
          that particular instance (like what fonts are available in that machine).
          Unlike cookies the user cannot opt-out of being tracked this way,
          so the browser has to avoid giving away that kind of hints.
     </p>
  </description>
  <url type="homepage">http://www.gnu.org/software/gnuzilla/</url>
  <screenshots>
    <screenshot type="default">
     <image>https://sagitter.fedorapeople.org/icecat-screenshots/icecat1.png</image>
    </screenshot>
    <screenshot>
     <image>https://sagitter.fedorapeople.org/icecat-screenshots/icecat2.png</image>
    </screenshot>
    <screenshot>
     <image>https://sagitter.fedorapeople.org/icecat-screenshots/icecat3.png</image>
    </screenshot>
    <screenshot>
     <image>https://sagitter.fedorapeople.org/icecat-screenshots/icecat4.png</image>
    </screenshot>
  </screenshots>
  <updatecontact>sagitter_at_fedoraproject.org</updatecontact>
</component>
EOF

cat > $RPM_BUILD_ROOT%{_datadir}/appdata/icecat.metainfo.xml <<EOF
<?xml version="1.0" encoding="UTF-8"?>
<component type="addon">
 <id>mozilla-requestpolicy</id>
 <extends>icecat.desktop</extends>
 <name>mozilla-requestpolicy</name>
 <summary>Extension that gives you control over cross-site requests</summary>
 <url type="homepage">https://requestpolicycontinued.github.io/</url>
 <url type="bugtracker">https://github.com/requestpolicycontinued/requestpolicy/issues</url>
 <metadata_license>CC0-1.0</metadata_license>
 <project_license>GPL-3.0+ and LGPL-3.0+</project_license>
</component>
EOF

%post
/bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
%if 0%{?fedora} < 25
/usr/bin/update-desktop-database &> /dev/null || :
%endif

%postun
if [ $1 -eq 0 ] ; then
    /bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null
    /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
fi
%if 0%{?fedora} < 25
/usr/bin/update-desktop-database &> /dev/null || :
%endif

%posttrans
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :

%check
desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/icecat.desktop
appstream-util validate-relax --nonet $RPM_BUILD_ROOT%{_datadir}/appdata/*.appdata.xml

%if %{build_langpacks}
%files -f %{name}.lang
%else
%files
%endif
%doc Changelog.IceCat README.* AUTHORS
%license LICENSE LEGAL COPYING-*
%{_bindir}/icecat
%{_datadir}/applications/icecat.desktop
%{_datadir}/icons/hicolor/*x*/apps/icecat*.png
%{_datadir}/appdata/icecat.appdata.xml
%{_datadir}/appdata/icecat.metainfo.xml
%{_mandir}/man1/%{name}*
%{icecatappdir}/browser/
%{icecatappdir}/webapprt/
%{icecatappdir}/defaults/
%{icecatappdir}/dictionaries/
%{icecatappdir}/icons/
%{icecatappdir}/icecat*
%{icecatappdir}/*.so
%{icecatappdir}/*.ini
%{icecatappdir}/omni.ja
%{icecatappdir}/updater
%{icecatappdir}/run-icecat.sh
%{icecatappdir}/dependentlibs.list
%{icecatappdir}/plugin-container
%{icecatappdir}/webapprt-stub
%{icecatappdir}/gmp-clearkey/

%exclude %{icecatappdir}/removed-files
%if 0%{build_langpacks}
%dir %{langpackdir}
%endif
%exclude %{_libdir}/%{icecat_devel}/
%exclude %{_datadir}/idl/%{icecat_ver}/
%exclude %{_includedir}/%{icecat_ver}/

%changelog
* Sat Feb 18 2017 Antonio Trande <sagitterATfedoraproject.org> 45.7.0-3
- Optimization flags disabled on arm/arm64

* Thu Feb 16 2017 Jens Lody <fedora@jenslody.de> - 45.7.0-3
- Fix gcc7 build, with backport of fix for mozb#1269171

* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 45.7.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

* Sat Feb 04 2017 Antonio Trande <sagitterATfedoraproject.org> 45.7.0-1
- Update to 45.7.0

* Sat Jan 21 2017 Antonio Trande <sagitterATfedoraproject.org> 45.5.1-7
- Test for trying ICU patch

* Fri Jan 20 2017 Antonio Trande <sagitterATfedoraproject.org> 45.5.1-6
- System ICU disabled on Fedora > 25

* Fri Jan 20 2017 Antonio Trande <sagitterATfedoraproject.org> 45.5.1-5
- Patched to make compatible with NSS 3.28.1 (bz#1414987)

* Thu Jan 05 2017 Antonio Trande <sagitterATfedoraproject.org> 45.5.1-4
- Conformed to new rules for scriptlets

* Tue Dec 13 2016 Caolán McNamara <caolanm@redhat.com> - 45.5.1-3
- rebuild for hunspell-1.5.4

* Fri Dec 02 2016 Antonio Trande <sagitterATfedoraproject.org> - 45.5.1-2
- Keep workaround for bz#1332926

* Fri Dec 02 2016 Antonio Trande <sagitterATfedoraproject.org> - 45.5.1-1
- Update to 45.5.1

* Sun Nov 27 2016 Antonio Trande <sagitterATfedoraproject.org> - 45.3.0-0.6.beta
- Debug build
- Debug builds patched (mozb#1013882)
- Patched for removing unnecessary warns

* Sun Sep 04 2016 Antonio Trande <sagitterATfedoraproject.org> - 45.3.0-0.5.beta
- Drop obsolete patch

* Sat Sep 03 2016 Antonio Trande <sagitterATfedoraproject.org> - 45.3.0-0.4.beta
- Use MOZ_SMP_FLAGS instead of MOZ_MAKE_FLAGS

* Thu Sep 01 2016 Antonio Trande <sagitterATfedoraproject.org> - 45.3.0-0.3.beta
- Update desktop file's translations
- Enable jemalloc

* Thu Sep 01 2016 Antonio Trande <sagitterATfedoraproject.org> - 45.3.0-0.2.beta
- Disable optimization on ARM

* Mon Aug 29 2016 Antonio Trande <sagitterATfedoraproject.org> - 45.3.0-0.1.beta
- Update to 45.3.0 (beta)
- Drop old patches
- Reset default compiler flags
- Filtering private libraries

* Fri Jul 22 2016 Tom Callaway <spot@fedoraproject.org> - 38.8.0-13
- rebuild for libvpx 1.6.0

* Wed Jun 29 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.8.0-12
- Optimization level increased to -O1

* Tue Jun 28 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.8.0-11
- Fix appadata file's tags

* Sun Jun 26 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.8.0-10
- Rebuild with newest icecat-38.8.0-gnu2 source archive (24 June)

* Sun Jun 26 2016 Jens Lody <fedora@jenslody.de> - 38.8.0-9
- Workaround for #1332926

* Sat Jun 18 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.8.0-8
- Set MOZ_SMP_FLAGS

* Sat Jun 18 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.8.0-7
- Undo latest change

* Sat Jun 18 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.8.0-6
- Set C++14 standard flag

* Fri Jun 17 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.8.0-5
- Set C++ standard flag

* Fri Jun 17 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.8.0-4
- Disable install stripping
- Disable builds for debugging

* Fri Jun 17 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.8.0-3
- Enable builds for debugging

* Fri May 13 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.8.0-2
- Remove additional flag

* Fri May 13 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.8.0-1
- Update to 38.8.0

* Mon Apr 18 2016 Caolán McNamara <caolanm@redhat.com> - 38.7.1-4
- rebuild for hunspell 1.4.0

* Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 38.7.1-3
- rebuild for ICU 57.1

* Sat Apr 09 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.7.1-2
- Downgrade optimization level on ARM

* Fri Apr 08 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.7.1-1
- Update to 38.7.1

* Thu Feb 04 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.6.0-1
- Update to 38.6.0
- Patched for GCC6 builds
- Cut off Provides bundled libraries except xulrunner

* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 38.5.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild 

* Mon Jan 04 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.5.2-4
- Fix description of appdata file

* Mon Jan 04 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.5.2-3
- Fix validating of desktop file

* Sun Jan 03 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.5.2-2
- .desktop .appdata and .metainfo files renamed (bz#1295234)

* Fri Jan 01 2016 Antonio Trande <sagitterATfedoraproject.org> - 38.5.2-1
- Update to 38.5.2

* Fri Dec 18 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.5.0-1
- Update to 38.5.0

* Tue Dec 08 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.4.0-3
- Force -fstack-protector-all flag (bz#1283307)

* Tue Dec  1 2015 Tom Callaway <spot@fedoraproject.org> - 38.4.0-2
- rebuild for libvpx 1.5.0

* Tue Nov 17 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.4.0-1
- Update to 38.4.0

* Tue Nov 03 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.3.0-12
- ARM neon support disabled on aarch64

* Sat Oct 31 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.3.0-11
- Rebuild for ICU 56

* Wed Oct 28 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.3.0-10
- Rebuild with RPM_LD_FLAGS

* Wed Oct 28 2015 David Tardon <dtardon@redhat.com> - 38.3.0-9
- rebuild for ICU 56.1

* Tue Oct 20 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.3.0-8
- Active hardened_build

* Tue Oct 13 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.3.0-7
- Rebuilt with updated Addons

* Mon Oct 12 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.3.0-6
- Fixed header files directory for freetype-2.6.1

* Mon Oct 12 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.3.0-5
- Languages packaged

* Tue Oct 06 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.3.0-4
- WebRTC disabled on extra arches

* Tue Oct 06 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.3.0-3
- Updated appdata and manpage files

* Mon Oct 05 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.3.0-2
- Disabled crashreporter on F22+

* Sat Oct 03 2015 Antonio Trande <sagitterATfedoraproject.org> - 38.3.0-1
- Update to 38.3.0
- Patches updated
- Language files not packaged
- Build defined for Gtk3 

* Thu Aug 13 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.8.0-5
- Added backported patch for CVE-2015-4473_4482_4488_4489_4491_4492 vulnerabilities

* Thu Aug 13 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.8.0-4
- Added backported patch for CVE-2015-4495 vulnerability

* Tue Jul 21 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.8.0-3
- Fixed on secondary arches

* Mon Jul 20 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.8.0-2
- Un-bundle libvpx-1.4

* Fri Jul 17 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.8.0-1
- Update to 31.8.0

* Sun Jul 12 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.7.0-8
- Packaged IceCat 31.7 in Fedora 21

* Fri Jul 03 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.7.0-7
- Fix .metainfo.xml file

* Thu Jul 02 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.7.0-6
- Added .metainfo.xml file

* Thu Jun 18 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.7.0-5
- Added options --enable-tree-freetype --enable-stdcxx-compat
- Added patch for Freetype-2.6 headers

* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 31.7.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild

* Sun Jun 14 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.7.0-3
- Re-built locale files
- Re-organized mozconfig options
- Compiled with ccache

* Wed Jun 10 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.7.0-2
- Unpacked files found

* Mon Jun 08 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.7.0-1
- Update to 31.7.0
- Make sure locale works for langpacks
- Set default bookmarks
- Made appdata file
- devel package obsoleted

* Mon May 04 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.6.0-6
- Required VPX from system for < F23

* Sun May 03 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.6.0-5
- libvpx-1.3.0 bundled only in >= F23

* Tue Apr 07 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.6.0-4
- Disable optimization flags (when GCC5 compiles) on ARM

* Tue Apr 07 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.6.0-3
- Compiled against bundle libvpx-1.3.0

* Mon Apr 06 2015 Tom Callaway <spot@fedoraproject.org> - 31.6.0-2
- Rebuild for libvpx 1.4.0

* Sat Apr 04 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.6.0-1
- Update to 31.6.0

* Mon Mar 16 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.5.0-2
- New rebuild to fix profile's storage problem

* Thu Mar 12 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.5.0-1
- Update to 31.5.0
- Patched to fix Mozilla Bug1021171
- crashreporter disabled on > F21
- Improved .desktop file

* Wed Feb 04 2015 Petr Machata <pmachata@redhat.com> - 31.4.0-5
- Bump for rebuild.

* Mon Feb 02 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.4.0-4
- Desktop file missing %%u (bz#1188078)

* Sat Jan 31 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.4.0-3
- Annulled the user-agent string customization

* Thu Jan 29 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.4.0-2
- Added %%license macro

* Thu Jan 29 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.4.0-1
- Update to 31.4.0
- Added MPLv2.0 license of HTML5-video-everywhere extension
- Description updated

* Mon Jan 26 2015 David Tardon <dtardon@redhat.com> - 31.2.0-8
- rebuild for ICU 54.1

* Wed Jan 21 2015 Antonio Trande <sagitterATfedoraproject.org> - 31.2.0-7
- Package now requires system-bookmarks (bz#1184297)

* Wed Nov 26 2014 Antonio Trande <sagitterATfedoraproject.org> - 31.2.0-6
- libjpeg-turbo unbundled (bz#1164815)

* Thu Nov 06 2014 Antonio Trande <sagitterATfedoraproject.org> - 31.2.0-5
- Added -Wno-error=declaration-after-statement
- Built against GStreamer-1.0
- Package compiled against bundled JPEG

* Sat Oct 25 2014 Antonio Trande <sagitterATfedoraproject.org> - 31.2.0-4
- Removed -fexceptions flags from Fedora optflags

* Thu Oct 23 2014 Antonio Trande <sagitterATfedoraproject.org> - 31.2.0-3
- Added -Wformat-security flags
- Added special link flags for ARM

* Wed Oct 22 2014 Antonio Trande <sagitterATfedoraproject.org> - 31.2.0-2
- Fixed compiler flags

* Tue Oct 21 2014 Antonio Trande <sagitterATfedoraproject.org> - 31.2.0-1
- Update to 31.2.0
- Added 'configure' options
- Built against system NSS/NSPR

* Thu Oct 16 2014 Antonio Trande <sagitterATfedoraproject.org> - 31.1.1-1
- Update to 31.1.1
- New bundled files (bz#1153135)
- Static sub-package is not built anymore
- Man-page updated
- Spyblock addon included

* Tue Aug 26 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-14
- Added "Provides: webclient"
- Installed manpage file

* Tue Aug 19 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-13
- Removed system xulrunner conditional
- Ghosted all .xpi language files (handled by %%find_lang)
- Added BSD, ISC, MIT, Apache2.0 licenses

* Sat Aug 09 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-12
- Removed HTTPS-everywhere RequestPolicy extensions (patch7)

* Thu Jul 24 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-11
- Remove precompiled .egg files
- Remove bundled jar/class files
- Delete chrpaths
- Added 'Public Domain' license
- Added a patch for using system Python Virtualenv (patch6)

* Wed Jul 16 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-10
- Added freetype2 system-headers list for Fedora>=21 (patch5)

* Fri Apr 04 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-9
- Defined other bundled() Provides

* Sat Mar 29 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-8
- Use system nspr

* Wed Mar 26 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-7
- Removed much more bundled files (added related BR packages)
- Build browser and xulrunner
- Added freetype2 reference patch

* Thu Feb 27 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-6
- Sources patched to use system ogg/opus/vorbis libraries
- Build browser alone

* Wed Feb 05 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-5
- Fix some executable permissions
- Added some tricks
- Build browser and xulrunner
- Defined a conditional macro for xulrunner
- Built a static sub-package
- Added COPYING separated license files
- Added bundled() Provides

* Mon Jan 27 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-4
- Build browser alone
- Added libffi/libpng linkage from system to .mozconfig file
- Added a patch to exclude APNG support missing error for libpng
- Added libpng-devel BR

* Tue Jan 14 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-3
- Removed bundled files
- Added nspr/nss Requires

* Wed Jan 08 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-2
- Timestamp preserving for the 'install' commands
- Added a comment interpretation to the License tag
- Defined all command calls in normal mode 

* Sun Jan 05 2014 Antonio Trande <sagitterATfedoraproject.org> - 24.0-1
- Initial package