Blob Blame History Raw
# Matches 1.0 tag.
%global commit 9c6289c5a088bf24f18f0b7bf8acaaf643aa411d
%global shortcommit %(c=%{commit}; echo ${c:0:7})

Name:		libxdiff
Version:	1.0
Release:	5%{?dist}
Summary:	Basic functionality to create difference/patches in binary and text
License:	LGPLv2+
URL:		https://github.com/spotrh/libxdiff
Source0:	https://github.com/spotrh/libxdiff/archive/%{commit}/%{name}-%{version}-%{shortcommit}.tar.gz
Patch0:		%{name}-1.0-big-endian.patch

%description
The LibXDiff library implements basic and yet complete functionalities to 
create file differences/patches to both binary and text files. The library 
uses memory files as file abstraction to achieve both performance and 
portability. For binary files, LibXDiff implements both (with some 
modification) the algorithm described in File System Support for Delta 
Compression by Joshua P. MacDonald, and the algorithm described in 
Fingerprinting By Random Polynomials by Michael O. Rabin. While for text 
files it follows directives described in An O(ND) Difference Algorithm 
and Its Variations by Eugene W. Myers.

This is a merged fork of the forks of the original libxdiff (0.23) found 
in the git and libgit2 source code, converted into a shared library.

%package devel
Summary:	Development libraries and headers for libxdiff
Requires:	%{name}%{?_isa} = %{version}-%{release}

%description devel
Development libraries and headers for libxdiff.

%prep
%setup -q -n %{name}-%{commit}
%patch0 -p1 -b .big-endian

%build
%configure --disable-static
make %{?_smp_mflags}

%install
make install DESTDIR=%{buildroot}
rm -rf %{buildroot}%{_libdir}/*.la

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%files
%doc AUTHORS COPYING README.md NEWS ChangeLog
%{_libdir}/libxdiff.so.*

%files devel
%{_includedir}/xdiff/
%{_libdir}/libxdiff.so
%{_libdir}/pkgconfig/libxdiff.pc

%changelog
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild

* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

* Wed Jun 19 2013 Dan HorĂ¡k <dan[at]danny.cz> - 1.0-2
- fix function on big-endian arches

* Thu May 30 2013 Tom Callaway <spot@fedoraproject.org> - 1.0-1
- initial package