Blob Blame History Raw
Name:           mail-notification
Version:        5.4
Release:        54%{?dist}
Summary:        Status icon that informs you if you have new mail

Group:          Applications/Internet
License:        GPLv3+
URL:            http://www.nongnu.org/mailnotify/
Source0:        http://savannah.nongnu.org/download/mailnotify/mail-notification-%{version}.tar.bz2
Patch0:		mail-notification-5.4-evolution.patch
Patch1:		mail-notification-5.4-gmime.patch
Patch2:		mail-notification-5.4-sasl_encode64.patch
Patch3:		mail-notification-5.4-evolution-gtkhtml.patch
Patch4:		mail-notification-5.4-camel_headers.patch
Patch5:		mail-notification-5.4-icons.patch
Patch6:		mail-notification-5.4-weak.patch
Patch7:		mail-notification-5.4-popup-attach.patch
Patch8:		mail-notification-5.4-kde-trayicon.patch
Patch9:		mail-notification-5.4-evolution-3-0-support.patch
Patch10:	mail-notification-5.4-gtk3-support.patch
Patch11:	mail-notification-5.4-build-without-optimalisations.patch
Patch12:	mail-notification-5.4-add-fallback-icon.patch
Patch13:	popup-markup.patch
Patch14:	mail-notification-5.4-make-properties-dialog-resizable.patch
Patch15:	mail-notification-5.4-prevent-memory-corruption-in-tooltips-code.patch
Patch16:	mail-notification-5.4-libemail.patch
Patch17:	mail-notification-5.4-prevent-stack-overflow-in-verify-ssl-certificate-function.patch

BuildRequires:  gettext
BuildRequires:  desktop-file-utils, scrollkeeper
BuildRequires:  openssl-devel >= 0.9.6
BuildRequires:  cyrus-sasl-devel >= 2.0
BuildRequires:  glib2-devel >= 2.14
BuildRequires:  gtk3-devel
BuildRequires:  GConf2-devel, libgnome-devel
BuildRequires:  dbus-glib-devel
BuildRequires:  libnotify-devel >= 0.4.1
BuildRequires:  gmime-devel >= 2.4
BuildRequires:  gnome-keyring-devel
BuildRequires:  perl-XML-Parser
# needed only when some .gob sources are changed, still not in rawhide...
#BuildRequires:  gob2 >= 2.0.16
BuildRequires:  evolution-devel 
BuildRequires:  evolution-data-server-devel >= 1.5

# needed for the gtk-builder-convert tool
BuildRequires:  gtk2-devel

# needed for the GConf RPM macros
BuildRequires:	GConf2

Requires:         hicolor-icon-theme

Requires(pre):    GConf2
Requires(post):   GConf2, scrollkeeper
Requires(preun):  GConf2
Requires(postun): scrollkeeper


%description
Mail Notification is a status icon (aka tray icon) that informs you if you
have new mail. It works with system trays implementing the freedesktop.org
System Tray Specification, such as the GNOME Panel Notification Area, the
Xfce Notification Area and the KDE System Tray.


%package        evolution-plugin
Summary:        Evolution plugin for Mail Notification
Group:          Applications/Internet
Requires:       %{name} = %{version}-%{release}
Obsoletes:	mail-notification < 3.0-4

%description	evolution-plugin
Evolution support for Mail Notification.


%prep
%setup -q
%patch0 -p1 -b .evolution
%patch1 -p1 -b .gmime
%patch2 -p1 -b .sasl_encode64
%patch3 -p1 -b .gtkhtml
%patch4 -p1 -b .camel_headers
%patch5 -p1 -b .icons
%patch6 -p1 -b .weak
%patch7 -p1 -b .popup_attach
%patch8 -p1 -b .kde_trayicon

# Evolution 3.0 requires a patch as the pkgconfig names have changed
# GTK3 requires various changes as well
%if 0%{?fedora} >= 15
%patch9 -p0 -b .evolution30
%patch10 -p0 -b .gtk3
%endif

# Temporary patch to build without any optimalisations so we
# can get better stacktraces for RHBZ #531088
%patch11 -p0 -b .gcc

# Don't throw assertion errors (and a possible crash) when
# some icons can't be found. Fixes RHBZ #654826
# This is a temporary workaround until GNOME BZ #629878 is fixed
%patch12 -p0 -b .fallback_icon

# Don't use <span> tags as XFCE's notification daemon doesn't understand those
%patch13 -p1 -b .span

# Make the mailbox properties dialog resizable
%patch14 -p0 -b .properties_resizable

# Prevent memory corruption in the tooltips code
%patch15 -p0 -b .tooltips_mem_corruption

# Prevent stack overflow in the verify_ssl_certificate function
# The POP3 and IMAP backends should only be affected by this
# https://bugzilla.redhat.com/show_bug.cgi?id=810054
%patch17 -p0 -b .stack_overflow_verify_ssl_certificate

#  Drop #line statements in C sources generated by .gob,
#  for the proper debuginfo package
pushd build/src
for f in *.c *.h
do
    sed -i '/^#line / d' $f
done
popd

# Convert the Glade UI to GtkBuilder
%if 0%{?fedora} >= 15
pushd ui
gtk-builder-convert mailbox-properties-dialog.glade mailbox-properties-dialog.ui
gtk-builder-convert properties-dialog.glade properties-dialog.ui
sed -i s@'<property name="has_separator">False</property>'@@ mailbox-properties-dialog.ui
sed -i s@'<property name="has_separator">False</property>'@@ properties-dialog.ui
popd
%endif

#  Adapt to evolution 3.3.5 libemail changes
%patch16 -p1 -b .libemail

%build

./jb configure \
	cc="%{__cc}" \
	cflags="$RPM_OPT_FLAGS" \
	cppflags="-D_GNU_SOURCE" \
	libs="-lX11" \
	destdir=$RPM_BUILD_ROOT \
	prefix=%{_prefix} \
	bindir=%{_bindir} \
	libdir=%{_libdir} \
	libexecdir=%{_libexecdir} \
	datadir=%{_datadir} \
	sysconfdir=%{_sysconfdir} \
	localstatedir=%{_localstatedir} \
	install-gconf-schemas=no

./jb build

# The build command above hides away all gcc commands and their warnings
# As they can be interesting show the build log manually
cat build/build.log


%install
# For GConf apps: prevent schemas from being installed at this stage
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1

./jb install

#  clear /var/lib/scrollkeeper stuff here
rm -rf $RPM_BUILD_ROOT%{_localstatedir}

find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'

chmod +x $RPM_BUILD_ROOT%{_libdir}/evolution/*/plugins/*.so

desktop-file-install --vendor fedora                   \
  --dir ${RPM_BUILD_ROOT}%{_datadir}/gnome/autostart/  \
  --delete-original                                    \
  ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart/mail-notification.desktop

desktop-file-install --vendor fedora                   \
  --dir ${RPM_BUILD_ROOT}%{_datadir}/applications      \
  --delete-original                                    \
  --add-category X-GNOME-NetworkSettings               \
  ${RPM_BUILD_ROOT}%{_datadir}/applications/mail-notification-properties.desktop

# Replace the Glade files with their GtkBuilder counterparts
%if 0%{?fedora} >= 15
pushd ui
rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/*.glade
install -m0644 mailbox-properties-dialog.ui $RPM_BUILD_ROOT%{_datadir}/%{name}/mailbox-properties-dialog.ui
install -m0644 properties-dialog.ui $RPM_BUILD_ROOT%{_datadir}/%{name}/properties-dialog.ui
popd
%endif

%find_lang %{name}


%pre
%gconf_schema_prepare %{name}


%post
%gconf_schema_upgrade %{name}

/usr/bin/scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :

touch --no-create %{_datadir}/icons/hicolor || :
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :


%preun
%gconf_schema_remove %{name}


%postun
/usr/bin/scrollkeeper-update -q ||:

touch --no-create %{_datadir}/icons/hicolor || :
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :


%files -f %{name}.lang
%doc AUTHORS COPYING NEWS README TODO
%{_sysconfdir}/gconf/schemas/mail-notification.schemas
%{_bindir}/*
%{_datadir}/%{name}
%{_datadir}/gnome/autostart/fedora-mail-notification.desktop
%{_datadir}/applications/fedora-mail-notification-properties.desktop
%{_datadir}/gnome/help/mail-notification/
%dir %{_datadir}/omf/mail-notification/
%{_datadir}/omf/mail-notification/mail-notification-C.omf
%{_datadir}/icons/hicolor/*/apps/mail-notification.*


%files evolution-plugin
%{_libdir}/evolution/*/plugins/*


%changelog
* Thu Apr  5 2012 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-54
- Fixed a stack overflow which occured while verifying SSL certificates
  for POP3 and IMAP mailboxes. RHBZ #810054

* Wed Mar 21 2012 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-53
- Fixed a posible segfault in the evolution plugin

* Wed Feb 22 2012 Milan Crha <mcrha@redhat.com> - 5.4-52
- Rebuild against newer evolution-data-server

* Wed Feb 08 2012 Milan Crha <mcrha@redhat.com> - 5.4-51
- Rebuild against newer evolution-data-server
- Add patch to build with evolution-3.3.5's libemail

* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4-50
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild

* Tue Dec 20 2011 Milan Crha <mcrha@redhat.com> - 5.4-49
- Rebuild against newer evolution-data-server

* Sat Dec 12 2011 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-48
- The evolution plugin is now compatible with evolution 3.2 and 3.4
- Pack the list of evolution mail folders in a GtkScrolledWindow
- Made the mailbox properties dialog resizable
- Fixed a memory corruption issue in the tooltips code
- RHBZ #682584: Use the GConf macros as mentioned at 
  https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#GConf
- Fixed a compatibility issue with libnotify 0.7 (attach-widget warnings)
- Dropped ancient obsoletes tags and triggers
- Dropped unneeded RPM tags

* Thu Nov 24 2011 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-47
- Fixed compatibility with latest evolution

* Sun Oct 30 2011 Bruno Wolff III <bruno@wolff.to> - 5.4-46
- Rebuild against newer evolution-data-server

* Tue Aug 30 2011 Milan Crha <mcrha@redhat.com> - 5.4-45
- Sync version with f16 branch

* Mon Aug 29 2011 Milan Crha <mcrha@redhat.com> - 5.4-44
- Rebuild against newer evolution-data-server

* Tue Aug 16 2011 Milan Crha <mcrha@redhat.com> - 5.4-43
- Rebuild against newer evolution-data-server

* Tue Jul 26 2011 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-42
- Rebuilt again because of new evolution-data-server

* Fri Jul  8 2011 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-41
- Rebuild against new evolution-data-server
- Removed the --sm-disable flag from the autostart file as it isn't
  working anymore (due to the dropped libgnomeui dep). RHBZ #718989

* Sun Jul  3 2011 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-40
- Updated the GTK3 patch so that popup windows are themed properly
  and the list of unread mails in popup windows are positioned properly
  Initial patch by Enrico Scholz (RHBZ #702097)

* Sat Jun 25 2011 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-39
- Fix markup with XFCE (RHBZ #715591)
  Thanks to Enrico Scholz for supplying a patch!

* Fri Jun 17 2011 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-38
- Fixed the compilation against the latest evolution
  More changes are still needed for full compatibility

* Wed Jun 15 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-37
- rebuild for new evolution-data-server

* Sun May 22 2011 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-36
- Fixed compatibility with evolution 3.1
- Fixed an GTK3 warning
- Clarified the need for the fallback icon patch as it turned out
  to be a regression introduced in gtk 2.21.8 (GNOME BZ #629878)

* Wed May 11 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-35
- rebuild for new evolution-data-server-3.1.1

* Fri Apr 15 2011 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-34
- Rebuild for evolution 3.0

* Thu Feb 17 2011 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-33
- Improved the gtk3 patch
- Don't throw assertion errors (and a possible crash) when
  some icons can't be found. Fixes RHBZ #654826
- (Temporary) build with -O0 in order to get more sane stacktraces so
  we can properly investigate and fix RHBZ #531088

* Tue Feb 15 2011 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-32
- Rebuilt for new gtk

* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4-31
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

* Wed Feb  2 2011 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-30
- Added support for evolution 3.0
- Ported the package to use GTK3 (as evolution requires GTK3)
- Replaced the libglade pieces by GtkBuilder
- Dropped the dependency on libgnomeui (but keep the libgnome dep for now)

* Tue Jan 11 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-29
- rebuild for new evolution-data-server-2.91.5

* Wed Dec 22 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-28
- rebuild for new libgtkhtml-3.15

* Sat Nov 13 2010 Erik van Pienbroek <epienbro@fedoraproject.org> - 5.4-27
- Add support for evolution 2.91+

* Fri Nov 12 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-26
- rebuild for new libnotify

* Mon Oct 11 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-25
- fix popup window place
  (#608372, by Erik van Pienbroek <erik-fedora@vanpienbroek.nl>)
- fix tray icon freezes on KDE when unread count reaches zero (#641580)
- support evolution 2.90+ (#642158, <mcrha@redhat.com>)

* Fri Sep 17 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-24
- add support for evolution 2.31+
  (#633507, by Erik van Pienbroek <erik-fedora@vanpienbroek.nl>)
  Combined with common evolution patch

* Thu Sep  9 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-23
- rebuild with new evolution-data-server

* Wed Jul 14 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-22
- rebuild with new gtkhtml3

* Tue Jun  8 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-21
- rebuild with new evolution-data-server

* Mon May 24 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-20
- change icon usage for Fedora 13 (#573809)
- fix some memory failures (Mat Booth <fedora@matbooth.co.uk>)

* Tue May  4 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-19
- rebuilt with new evolution-data-server

* Fri Feb 16 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-18
- rebuilt with gmime-2.6
- explicitly link with libX11 (#564739)

* Mon Feb  1 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-17
- update evolution patch (#538956, by Matthew Barnes <mbarnes@redhat.com>)

* Sat Aug 22 2009 Tomas Mraz <tmraz@redhat.com> - 5.4-16
- rebuilt with new openssl

* Fri Aug 21 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-14
- add gtkhtml3-devel pkgconfig requirements into config stuff
  for evolution plugin build

* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

* Tue May 19 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-11
- add patch for new cyrus-sasl's ABI (Jan F. Chadima, #501456)

* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild

* Wed Feb 04 2009 Caolán McNamara <caolanm@redhat.com> - 5.4-9
- rebuild for dependencies

* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 5.4-8
- rebuild with new openssl

* Mon Dec 22 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-7
- rebuild with new gmime-2.4

* Wed Dec 17 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-6
- rebuild for dependencies

* Sat Nov 29 2008 Caolán McNamara <caolanm@redhat.com> - 5.4-5
- rebuild for dependencies

* Mon Oct 27 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-4
- fix plugin permissions (#468524)

* Wed Oct  1 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-3
- add patch for evolution >= 2.23.5 (#464779)

* Mon Aug 11 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-2
- rebuild for new evolution-2.24 (#458587)

* Mon Jun 30 2008 Dmitry Butskoy <Dmitry@Butskoy.name>
- drop X-Fedora category from desktop files
- use X-GNOME-NetworkSettings (instead of X-GNOME-PersonalSettings)
  for the preferences desktop file (#453262)

* Wed Jun  4 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.4-1
- update to 5.4 (#445345)

* Mon May 19 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.3-2
- add triggerpostun scriptlet to handle broken preun scriptlets
  of packages before Fedora 9 (mail-notification < 5.0) (#446315)

* Mon Apr 28 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.3-1
- update to 5.3
- scriptlets cleanups

* Wed Apr  9 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.2-3
- add cache-crash patch from upstream (#440433)

* Tue Mar 25 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.2-2
- drop extra '#line" statements from pre-generated C sources
  (needed for debuginfo package)

* Mon Mar 24 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.2-1
- Upgrade to 5.2

* Thu Feb 14 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 5.0-3
- rebuild for Fedora 9

* Thu Jan 31 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 5.0-2
- add http://launchpadlibrarian.net/11684452/mail-notification-5.0-eelfix.diff
  from https://bugs.launchpad.net/bugs/180400

* Fri Jan 04 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 5.0-1
- Update to 5.0

* Wed Dec 05 2007 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 5.0-0.2.rc1
- rebuild for new libssl.so.6/libcrypto.so.6

* Wed Nov 28 2007 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 5.0-0.1.rc1
- Update to 5.0-rc1
- drop patches now upstream
- update gconf scripts

* Fri Nov 23 2007 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 4.1-5
- Rebuild against evo 2.21

* Sun Aug 26 2007 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 4.1-4
- add mail-notification-evo-api-change.patch to fix compilation against
  evo 2.12 (taken from ubuntu's gutsy package -- thx guys!)

* Fri Aug 03 2007 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info>
- Update License field due to the "Licensing guidelines changes"

* Sun Jul 22 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info>  4.1-3
- Add Desktop-Category X-GNOME-PersonalSettings (#249181)

* Thu Jun 28 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info>  4.1-2
- temporary add patch to make configure find the evolution-plugin stuff

* Tue Jun 26 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info>  4.1-1
- Update to 4.1
- Drop mail-notification-fix_gdk_deadlock.patch (fixed upstream)

* Fri Mar 09 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info>  4.0-2
- Apply patch from Erik van Pienbroek to fix #227828 (needed for new
  at-spi)

* Wed Jan 17 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info>  4.0-1
- Update to 4.0 final

* Wed Dec 20 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  4.0-0.3.rc2
- Rebuild

* Thu Dec 07 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  4.0-0.2.rc2
- Update to 4.0rc2

* Tue Nov 28 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  4.0-0.1.rc1
- Update to 4.0rc1
- remove some unneeded workarounds and patches
- require hicolor-icon-theme

* Tue Nov 21 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  3.0-11
- add mail-notification-mail-reader-launch.patch (#215119, credits go to
  John Conroy)

* Thu Nov 09 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  3.0-10
- Update patch

* Sat Nov 04 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  3.0-9
- add a patch that informs the user to install the evolution-plugin if
  he want to use mn with evo

* Sun Oct 29 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  3.0-8
- add workaround that hacks configure to allow building with evo 2.10

* Sat Sep 02 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  3.0-7
- don't run mail-notification with unset-obsolete-configuration at all

* Tue Aug 29 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  3.0-6
- add BR perl-XML-Parser ;-)

* Mon Aug 28 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  3.0-5
- Rebuild for devel
- run unset-obsolete-configuration only works when DISPLAY is set; will
  report upstream

* Sat Jul 15 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  3.0-4
- Package evolution plugin separately

* Sat Jul 15 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  3.0-3
- rebuild for new gail
- send ouput from unset-obsolete-configuration to /dev/null and ignore retval

* Sun Jul 02 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  3.0-2
- unset-obsolete-configuration in post

* Wed Jun 14 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  3.0-1
- Update to 3.0

* Fri Jun 02 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>  3.0-0.1.rc2
- Update to 3.0-rc2 (with some help from Joseph E. Sacco, Ph.D.)

* Tue May 30 2006 Radek Vokal <rvokal@redhat.com> 2.0-13
- fixed for evolution 2.7

* Thu Apr 27 2006 Paul Clifford <paul.clifford+fe[AT]gmail[DOT]com> 2.0-12
- Added patch for IMAP authentication problem from project homepage (#190137)

* Mon Feb 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info>
- Rebuild for Fedora Extras 5

* Mon Jan 30 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> 2.0-10
- rebuild

* Thu Jan 17 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> 2.0-9
- fixes for evolution >= 2.5

* Thu Jan 17 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> 2.0-8
- rebuild

* Thu Nov 10 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> 2.0-7
- rebuild against new openssl
- use LDFLAGS and not CFLAGS for fixing #172010

* Sat Nov 05 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> 2.0-6
- Fix #172010 with export CFLAGS="-Wl,--export-dynamic" for now
- BR evolution-data-server-devel
- Use --disable-schemas-install

* Thu Sep 22 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> 2.0-5
- BR evo-devel

* Tue Sep 20 2005 Radek Vokal <rvokal@redhat.com> 2.0-4
- add mail-notification-evolution.patch and enable evo-support

* Sat Sep 03 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.0-3
- rebuild for new icu

* Fri Aug 19 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.0-2
- rebuild

* Wed Aug 10 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.0-1
- Update to 2.0 -- build without evolution support for now (seems it
  needs the whole evo-source)
- Use dist
- Add two patches
- New BR gob2

* Wed May 18 2005 Colin Charles <colin@fedoraproject.org> - 1.1.-3
- bump release, request build for ppc

* Fri Apr  1 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.1-2
- Include mail-notification directory in datadir/omf.

* Mon Mar 07 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:1.1-1
- update to 1.1
- remove gmail build option and add new BR libicu-devel

* Tue Nov 25 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:1.0-0.fdr.1
- update to 1.0

* Tue Nov 16 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:0.99-0.fdr.1
- update to 0.99
- rename mail-notfication-README.FEDORA to mail-notification-README.FEDORA
- Add BR gnutls-devel and libgcrypt-devel for gmail build

* Tue Nov 09 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:0.8.1-0.fdr.3
- trim build comment
- own _datadir/gnome/help/mail-notification/
- rename SOURCE1 from README.FEDORA to mail-notfication-README.FEDORA


* Sat Nov 06 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:0.8.1-0.fdr.2
- Really remove "killall bonobo-activation-server"; Add a README.FEDORA
  which descibes the problem.
- Spilt post,preun,postun sections
- Use --with gmail to build for FC3 with gmail-support

* Thu Nov 04 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:0.8.1-0.fdr.1
- Update to 0.8.1

* Thu Nov 04 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:0.8.0-0.fdr.1
- Update to 0.8.0

* Sun Oct 28 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:0.7.1-0.fdr.1
- Update to 0.7.1
- BR gettext

* Sun Oct 17 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:0.7.0-0.fdr.1
- Update to 0.7.0
- Add gmime dependency
- No gmailsupport until FC3
- Removed "killall bonobo-activation-server" again -- bad idea it seems

* Tue Sep 14 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:0.6.2-0.fdr.1
- Update to 0.6.2
- After talkback with program author added "killall bonobo-activation-server"
  to post section

* Sun Aug 29 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:0.6.1-0.fdr.1
- Initial RPM release.