Blob Blame History Raw
# Conditional for release and snapshot builds. Uncomment for release-builds.
%global rel_build 1

# This is needed, because src-url contains branched part of versioning-scheme.
%global branch 1.17

# Settings used for build from snapshots.
%{!?rel_build:%global commit 922d0e0219b1bedcece8624e4b5fd7e15e7a9bd5}
%{!?rel_build:%global commit_date 20131113}
%{!?rel_build:%global shortcommit %(c=%{commit};echo ${c:0:7})}
%{!?rel_build:%global git_ver git%{commit_date}-%{shortcommit}}
%{!?rel_build:%global git_rel .git%{commit_date}.%{shortcommit}}
%{!?rel_build:%global git_tar %{name}-%{version}-%{git_ver}.tar.xz}

Name:          mate-control-center
Version:       %{branch}.2
%if 0%{?rel_build}
Release:       1%{?dist}
%else
Release:       0.6%{?git_rel}%{?dist}
%endif
Summary:       MATE Desktop control-center
License:       LGPLv2+ and GPLv2+
URL:           http://mate-desktop.org

# for downloading the tarball use 'spectool -g -R mate-control-center.spec'
# Source for release-builds.
%{?rel_build:Source0:     http://pub.mate-desktop.org/releases/%{branch}/%{name}-%{version}.tar.xz}
# Source for snapshot-builds.
%{!?rel_build:Source0:    http://git.mate-desktop.org/%{name}/snapshot/%{name}-%{commit}.tar.xz#/%{git_tar}}

#font-preview
Patch6:        mate-control-center_fv-import-SushiFontLoader-and-SushiFontWidget.patch
Patch7:        mate-control-center_fv-thumbnailer-use-SushiFontLoader.patch
Patch8:        mate-control-center_fv-port-to-SushiFontWidget-and-GtkApplication-1.17.patch
Patch9:        mate-control-center_fv-remove-ftstream-vfs.patch
Patch10:       mate-control-center_fv-import-GdMainToolbar.patch
Patch11:       mate-control-center_fv-use-new-style-interface-1.13.patch
Patch12:       mate-control-center_fv-add-FontViewModel.patch
Patch13:       mate-control-center_fv-thumbnailer-respect-the-passed-in-size-argument.patch
Patch14:       mate-control-center_fv-first-pass-at-integrating-an-overview-mode.patch
Patch15:       mate-control-center_fv-thumbnailer-port-to-cairo-rendering.patch
Patch16:       mate-control-center_fv-add-an-application-menu.patch
Patch17:       mate-control-center_fv-adjust-desktop-file.patch
Patch18:       mate-control-center_fv-make-sure-rendered-text-is-black-on-white.patch
Patch19:       mate-control-center_fv-font-widget-sync-from-Sushi.patch
Patch20:       mate-control-center_fv-font-model-fallback-icon-if-we-fail-thumbnailing-the-font-file.patch
Patch21:       mate-control-center_fv-Safely-init-FontConfig-once-for-the-whole-app.patch
Patch22:       mate-control-center_fv-do-not-recreate-different-SushiFontWidget-every-time.patch
Patch23:       mate-control-center_fv-font-widget-another-sync-from-Sushi.patch
Patch24:       mate-control-center_fv-main-toolbar-sync-with-Documents.patch
Patch25:       mate-control-center_fv-font-model-install-file-monitors-on-fontconfig-font-directories.patch
Patch26:       mate-control-center_fv-refresh-Install-button-appearance-when-model-changes.patch
Patch27:       mate-control-center_fv-font-model-add-API-to-get-an-iter-from-a-FT_Face.patch
Patch28:       mate-control-center_fv-match-the-font-face-when-getting-an-iter-to-update-the-button.patch
Patch29:       mate-control-center_fv-font-model-set-a-fallback-icon-if-we-fail-to-read-the-thumbnail.patch
Patch30:       mate-control-center_fv-main-toolbar-another-sync-with-Documents.patch
Patch31:       mate-control-center_fv-do-not-hardcode-fonts-hone-dir-as-target-install-directory.patch
Patch32:       mate-control-center_fv-font-model-do-not-use-sync-g_file_query_info.patch
Patch33:       mate-control-center_fv-font-model-use-g_io_scheduler_push_job-to-refactor-thumbnailing-code.patch
Patch34:       mate-control-center_fv-font-model-use-g_utf8_collation_key-to-sort-the-model.patch
Patch35:       mate-control-center_fv-font-widget-one-more-sync-from-Sushi.patch
Patch36:       mate-control-center_fv-font-model-cache-the-fallback-icon-in-the-private-struct.patch
Patch37:       mate-control-center_fv-font-model-cache-tree-iters-when-setting-values-on-the-model.patch
Patch38:       mate-control-center_fv-font-model-use-a-single-IO-scheduler-job-to-load-thumbnail-images.patch
Patch39:       mate-control-center_fv-font-model-load-font-names-asynchronously.patch
Patch40:       mate-control-center_fv-set-an-empty-title-on-the-info-dialog.patch
Patch41:       mate-control-center_fv-font-model-cancel-previous-loading-when-refreshing-font-list.patch
Patch42:       mate-control-center_fv-font-model-actually-cancel-the-thread-when-rebuilding-font-list.patch
Patch43:       mate-control-center_fv-font-model-emit-config-changed-when-reloading-the-font-list.patch
Patch44:       mate-control-center_fv-font-view-show-an-error-dialog-when-unable-to-load-a-font.patch
Patch45:       mate-control-center_fv-next-sync-from-Sushi.patch
Patch46:       mate-control-center_fv-do-not-crash-when-opening-a-non-existing-file.patch
Patch47:       mate-control-center_fv-font-view-return-early-if-we-have-a-model-already.patch
Patch48:       mate-control-center_fv-thumnailer-do-not-paint-a-white-background-under-thumbnails.patch
Patch49:       mate-control-center_fv-do-not-call-g_type_init.patch
Patch50:       mate-control-center_fv-font-widget-next-2-sync-from-sushi.patch
Patch51:       mate-control-center_fv-font-widget-next-3-sync-from-sushi.patch
Patch52:       mate-control-center_fv-font-model-drop-gtk_icon_info_free.patch
Patch53:       mate-control-center_fv-font-view-add-a-title-to-the-info-dialog.patch
Patch54:       mate-control-center_fv-fix-an-uninitialized-variable.patch
Patch55:       mate-control-center_fv-deprecated-gtk_misc_set_alignment-and-margin-left-right-1.13.patch
Patch56:       mate-control-center_fv-replace-deprecated-method-with-main-context-invocation.patch
Patch57:       mate-control-center_fv-ported-thumbnailing-io-scheduler-job-to-g_task_run_in_thread.patch
Patch58:       mate-control-center_fv-replace-io-scheduler-with-g_task_run_in_thread-in-load_font-infos.patch
Patch59:       mate-control-center_fv-sushi-font-loader-sync-from-sushi.patch
Patch60:       mate-control-center_fv-gd-toolbar-sync-to-latest-libgd-suitable-for-mate.patch
Patch61:       mate-control-center_add-style-class-font-viewer-at-top-level.patch

# not used
#Patch9:        mate-control-center_fv-fix-ununsed-variables-GCC-warnings.patch
#Patch12:       mate-control-center_fv-fix-deprecated-gtk_scrolled_window_add_with_viewport.patch

BuildRequires: dconf-devel
BuildRequires: desktop-file-utils
BuildRequires: gtk3-devel
BuildRequires: libcanberra-devel
BuildRequires: libmatekbd-devel
BuildRequires: librsvg2-devel
BuildRequires: libSM-devel
BuildRequires: libXScrnSaver-devel
BuildRequires: libXxf86misc-devel
BuildRequires: mate-common
BuildRequires: mate-desktop-devel
BuildRequires: mate-menus-devel
BuildRequires: mate-settings-daemon-devel
BuildRequires: marco-devel

Requires: gsettings-desktop-schemas
# rhbz (#1234438)
Requires: mate-settings-daemon
# keyring support
Requires: gnome-keyring
Requires: %{name}-filesystem%{?_isa} = %{version}-%{release}


%description 
MATE Control Center configures system settings such as themes,
keyboards shortcuts, etc.

%package filesystem
Summary:      MATE Control Center directories
# NOTE: this is an "inverse dep" subpackage. It gets pulled in
# NOTE: by the main package an MUST not depend on the main package

%description filesystem
The MATE control-center provides a number of extension points
for applications. This package contains directories where applications
can install configuration files that are picked up by the control-center
utilities.

%package devel
Summary:      Development files for mate-settings-daemon
Requires:       %{name}%{?_isa} = %{version}-%{release}

%description devel
Development files for mate-control-center


%prep
%setup -q%{!?rel_build:n %{name}-%{commit}}

%patch6 -p1 -b .import-SushiFontLoader-and-SushiFontWidget
%patch7 -p1 -b .thumbnailer-use-SushiFontLoader
%patch8 -p1 -b .port-to-SushiFontWidget-and-GtkApplication
%patch9 -p1 -b .remove-ftstream-vfs
%patch10 -p1 -b .import-GdMainToolbar
%patch11 -p1 -b .use-new-style-interface
%patch12 -p1 -b .add-FontViewModel
%patch13 -p1 -b .thumbnailer-respect
%patch14 -p1 -b .first-pass-at-integrating-an-overview-mode
%patch15 -p1 -b .thumbnailer-port-to-cairo-rendering
%patch16 -p1 -b .add-an-application-menu
%patch17 -p1 -b .adjust-desktop-file
%patch18 -p1 -b .make-sure-rendered-text-is-black-on-white.patch
%patch19 -p1 -b .font-widget-sync-from-Sushi.patch
%patch20 -p1 -b .font-model-fallback-icon-if-we-fail-thumbnailing-the-font-file.patch
%patch21 -p1 -b .Safely-init-FontConfig-once-for-the-whole-app.patch
%patch22 -p1 -b .do-not-recreate-different-SushiFontWidget-every-time.patch
%patch23 -p1 -b .font-widget-another-sync-from-Sushi.patch
%patch24 -p1 -b .main-toolbar-sync-with-Documents.patch
%patch25 -p1 -b .font-model-install-file-monitors-on-fontconfig-font-directories.patch
%patch26 -p1 -b .refresh-Install-button-appearance-when-model-changes.patch
%patch27 -p1 -b .font-model-add-API-to-get-an-iter-from-a-FT_Face.patch
%patch28 -p1 -b .match-the-font-face-when-getting-an-iter-to-update-the-button.patch
%patch29 -p1 -b .font-model-set-a-fallback-icon-if-we-fail-to-read-the-thumbnail.patch
%patch30 -p1 -b .main-toolbar-another-sync-with-Documents.patch
%patch31 -p1 -b .do-not-hardcode-fonts-hone-dir-as-target-install-directory
%patch32 -p1 -b .font-model-do-not-use-sync-g_file_query_info
%patch33 -p1 -b .font-model-use-g_io_scheduler_push_job-to-refactor-thumbnailing-code
%patch34 -p1 -b .font-model-use-g_utf8_collation_key-to-sort-the-model
%patch35 -p1 -b .font-widget-one-more-sync-from-Sushi
%patch36 -p1 -b .font-model-cache-the-fallback-icon-in-the-private-struct
%patch37 -p1 -b .font-model-cache-tree-iters-when-setting-values-on-the-model
%patch38 -p1 -b .font-model-use-a-single-IO-scheduler-job-to-load-thumbnail-images
%patch39 -p1 -b .font-model-load-font-names-asynchronously
%patch40 -p1 -b .set-an-empty-title-on-the-info-dialog
%patch41 -p1 -b .font-model-cancel-previous-loading-when-refreshing-font-list
%patch42 -p1 -b .font-model-actually-cancel-the-thread-when-rebuilding-font-list
%patch43 -p1 -b .font-model-emit-config-changed-when-reloading-the-font-list
%patch44 -p1 -b .font-view-show-an-error-dialog-when-unable-to-load-a-font
%patch45 -p1 -b .next-sync-from-Sushi
%patch46 -p1 -b .do-not-crash-when-opening-a-non-existing-file
%patch47 -p1 -b .font-view-return-early-if-we-have-a-model-already
%patch48 -p1 -b .thumnailer-do-not-paint-a-white-background-under-thumbnails
%patch49 -p1 -b .do-not-call-g_type_init
%patch50 -p1 -b .font-widget-next-2-sync-from-sushi
%patch51 -p1 -b .font-widget-next-3-sync-from-sushi
%patch52 -p1 -b .font-model-drop-gtk_icon_info_free
%patch53 -p1 -b .font-view-add-a-title-to-the-info-dialog
%patch54 -p1 -b .fix-an-uninitialized-variable
%patch55 -p1 -b .deprecated-gtk_misc_set_alignment-and-margin-left-right
%patch56 -p1 -b .replace-deprecated-method-with-main-context-invocation
%patch57 -p1 -b .ported-thumbnailing-io-scheduler-job-to-g_task_run_in_thread
%patch58 -p1 -b .replace-io-scheduler-with-g_task_run_in_thread-in-load_font-infos
%patch59 -p1 -b .sushi-font-loader-sync-from-sushi
%patch60 -p1 -b .gd-toolbar-sync-to-latest-libgd-suitable-for-mate
%patch61 -p1 -b .add-style-class-font-viewer
# end fontviewer

autoreconf -fi

%if 0%{?rel_build}
#NOCONFIGURE=1 ./autogen.sh
%else # 0%{?rel_build}
# needed for git snapshots
NOCONFIGURE=1 ./autogen.sh
%endif # 0%{?rel_build}

%build
%configure                           \
           --disable-static          \
           --disable-schemas-compile \
           --disable-update-mimedb

# remove unused-direct-shlib-dependency
sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool

make %{?_smp_mflags} V=1


%install
%{make_install}

find %{buildroot} -name '*.la' -exec rm -rf {} ';'
find %{buildroot} -name '*.a' -exec rm -rf {} ';'

desktop-file-install                                \
    --delete-original                               \
    --dir=%{buildroot}%{_datadir}/applications      \
%{buildroot}%{_datadir}/applications/*.desktop

# delete mime cache
rm %{buildroot}%{_datadir}/applications/mimeinfo.cache

%find_lang %{name} --with-gnome --all-name


%post
/sbin/ldconfig
/usr/bin/update-desktop-database &> /dev/null || :
/bin/touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
/bin/touch --no-create %{_datadir}/mime/packages &> /dev/null || :

%postun
/sbin/ldconfig
/usr/bin/update-desktop-database &> /dev/null || :
if [ $1 -eq 0 ] ; then
    /bin/touch --no-create %{_datadir}/icons/hicolor &> /dev/null
    /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
    /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
    /bin/touch --no-create %{_datadir}/mime/packages &> /dev/null || :
    /usr/bin/update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
fi

%posttrans
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
/usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
/usr/bin/update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :


%files -f %{name}.lang
%doc AUTHORS COPYING README
%config %{_sysconfdir}/xdg/menus/matecc.menu
%{_bindir}/mate-*
%{_libdir}/libmate-window-settings.so.*
%{_libdir}/window-manager-settings
%{_libdir}/libmate-slab.so.*
%{_sbindir}/mate-display-properties-install-systemwide
%{_datadir}/applications/*.desktop
%{_datadir}/desktop-directories/matecc.directory
%{_datadir}/icons/hicolor/*/apps/*.png
%{_datadir}/icons/hicolor/scalable/apps/mate-*.svg
%{_datadir}/glib-2.0/schemas/org.mate.*.xml
%{_datadir}/mate-control-center/*
%{_datadir}/mime/packages/mate-theme-package.xml
%{_datadir}/thumbnailers/mate-font-viewer.thumbnailer
%{_datadir}/polkit-1/actions/org.mate.randr.policy
%{_mandir}/man1/mate-*.1.*

%files filesystem
%dir %{_datadir}/mate-control-center
%dir %{_datadir}/mate-control-center/keybindings

%files devel
%{_includedir}/mate-window-settings-2.0
%{_libdir}/pkgconfig/mate-window-settings-2.0.pc
%{_libdir}/libmate-window-settings.so
%{_libdir}/pkgconfig/mate-default-applications.pc
%{_libdir}/pkgconfig/mate-keybindings.pc
%{_includedir}/libmate-slab/
%{_libdir}/libmate-slab.so
%{_libdir}/pkgconfig/mate-slab.pc


%changelog
* Wed Jan 25 2017 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.17.2-1
- update 1.17.2 to release with libinput support

* Tue Dec 06 2016 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.17.0-1
- update 1.17.0 release

* Thu Sep 22 2016 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.16.0-1
- update to 1.16.0 release

* Fri Sep 09 2016 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.15.2-1
- update to 1.15.2 release

* Sat Jul 02 2016 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.15.1-1
- update to 1.15.1 release

* Mon Jun 27 2016 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.15.0-2
- don't show broken elements

* Thu Jun 09 2016 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.15.0-1
- update to 1.15.0 release
- switch to gtk+3

* Wed Apr 06 2016 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.14.0-1
- update to 1.14.0 release

* Mon Feb 22 2016 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.13.2-1
- update to 1.13.2 release

* Sun Feb 07 2016 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.13.1-1
- update to 1.13.1

* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

* Sun Dec 27 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.12.1-2
- move mate-menus-preferences-category-menu to mate-menus

* Mon Dec 14 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.12.1-1
- update to 1.12.1 release
- remove a upstreamed patch

* Wed Dec 02 2015 Rex Dieter <rdieter@fedoraproject.org> 1.12.0-3
- Obsoletes/Provides: mate-menus-preferences-category-menu (#1287845)

* Fri Nov 13 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.12.0-2
- fix crash with display-properties

* Fri Nov 06 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.12.0-1
- update to 1.12.0 release
- include mate-preferences-categories.menu from mate-menus

* Wed Oct 21 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.11.0-1
- update to 1.11.0 release

* Tue Oct 06 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.10.2.1
- update to 1.10.2 release

* Mon Jul 13 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.10.1-1
- update to 1.10.1 release

* Wed Jun 24 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.10.0-3
- add runtime requires mate-settings-daemon
- fix rhbz (#1234438)

* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild

* Tue May 05 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.10.0-1
- update to 1.10.0-1 release

* Thu Mar 05 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.9.90.2
- fix pkexec issue with mate-control-center, rhbz (#972534)

* Thu Mar 05 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.9.90.1
- update to 1.9.90 release

* Tue Jan 20 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.9.1-1
- update to 1.9.1 release

* Sun Oct 26 2014 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.9.0-1
- update to 1.9.0 release
- windows: Add option to configure titlebar buttons layout
- appearance: Add support for metacity-theme-2.xml
- default-applications: Add support for office applications

* Wed Oct 01 2014 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.8.3-1
- update to 1.8.3 release

* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild

* Tue Aug 12 2014 Rex Dieter <rdieter@fedoraproject.org> 1.8.2-2
- update mime scriptlet 

* Sat Jul 12 2014 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.8.2-1
- update to 1.8.2 release
- removeed upstreamed typo-in-gsettings-key.patch

* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

* Sat Apr 19 2014 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.8.1-2
- typo in gsettings key, rhbz (#1089461)

* Sun Mar 16 2014 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.8.1-1
- update to 1.8.1 release
- use wildcards for man files extensions
- remove --disable-scrollkeeper configure flag

* Wed Mar 05 2014 Dan Mashal <dan.mashal@fedoraproject.org> - 1.8.0-1
- Update to 1.8.0

* Wed Feb 19 2014 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.7.90-1
- update to 1.7.90
- repair usage of git snapshots
- improve find language command for yelp-tools
- move autoreconf to the right place

* Thu Feb 13 2014 Dan Mashal <dan.mashal@fedoraproject.org> 1.7.0-2
- Add autoreconf to work around rpath.

* Sun Feb 09 2014 Dan Mashal <dan.mashal@fedoraproject.org> 1.7.0-1
- Update to 1.7.0 release.

* Sat Dec 21 2013 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.7.0-0.2.git20131113.922d0e0
- make Maintainers life easier and use better git snapshot usage, Thanks to Björn Esser
- use BR marco-devel
- remove Obsoletes: libslab line, no need anymore
- fix mixed usage of tabs and spaces
- use modern 'make install' macro
- make configure command better readable

* Fri Dec 06 2013 Dan Mashal <dan.mashal@fedoraproject.org> 1.7.0-1.1.git922d0e0
- Update to 1.7.0

* Sat Oct 19 2013 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.6.1-3
- switch to gnome-keyring for > f19

* Wed Jul 31 2013 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.6.1-2
- add mate-control-center-file-system subpackage
- add requires hicolor-icon-theme

* Tue Jul 30 2013 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.6.1-1
- update to 1.6.1 release
- remove NOCONFIGURE=1 ./autogen.sh
- update file section
- remove old remnants from spec file

* Sat Jun 29 2013 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.6.0-2
- add runtime require gsettings-desktop-schemas to have proxy support
- from gnome gsettings schema
- remove needless mate-control-center.convert file
- remove unused-direct-shlib-dependency to avoid rpmlint warnings
- cleanup BR's

* Wed Apr 03 2013 Dan Mashal <dan.mashal@fedoraproject.org> - 1.6.0-1
- Update to latest 1.6.0 stable release.

* Mon Mar 25 2013 Dan Mashal <dan.mashal@fedoraproject.org> - 1.5.5-3
- Readd desktop file install and remove desktop file validate
- Own proper dirs
- Use buildroot macro instead of rpm_build_root

* Mon Mar 25 2013 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.5.5-2
- bump version in spec file

* Sun Mar 24 2013 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1.5.5-1
- update to new upstream release
- remove desktop-file-install command
- add desktop-file-validate command
- fix icon cache rpm scriptlet

* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.3-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

* Thu Jan 17 2013 Rex Dieter <rdieter@fedoraproject.org> 1.5.3-3
- fix obsoletes
- sort BuildRequires

* Wed Jan 16 2013 Dan Mashal <dan.mashal@fedoraproject.org> - 1.5.3-2
- Fix conflicts

* Tue Jan 15 2013 Dan Mashal <dan.mashal@fedoraproject.org> - 1.5.3-1
- Update to latest upstream release.

* Fri Jan 11 2013 Dan Mashal <dan.mashal@fedoraproject.org> - 1.5.2-2
- Switch back to old BR scheme.
- Drop unneeded BR's
- Add upstream patch to fix tielbar actions

* Fri Dec 21 2012 Nelson Marques <nmarques@fedoraproject.org> - 1.5.2-1
- Update to version 1.5.2 so we can receive mate-panel 1.5.3
- Remove dropped BRs: MateCORBA-2.0 
- Split out libslab (now distributed)
- Minor rework for readibility and ordered BuildRequires

* Sun Nov 25 2012 Dan Mashal <dan.mashal@fedoraproject.org> - 1.5.1-1
- Bump to 1.5.1 release

* Thu Nov 08 2012 Leigh Scott <leigh123linux@googlemail.com> - 1.5.0-2
- patch with latest upstream fixes

* Mon Oct 29 2012 Leigh Scott <leigh123linux@googlemail.com> - 1.5.0-1
- update to 1.5.0 release
- change build requires and change style
- add requires gsettings-desktop-schemas
- add build requires gsettings-desktop-schemas-devel
- add schema scriptlets
- add build requires dconf-devel 

* Tue Oct 16 2012 Leigh Scott <leigh123linux@googlemail.com> - 1.4.0-9
- move unversioned .so back to main package
- fix directory ownership
- fix scriplets
- add missing build requires

* Wed Oct 03 2012 Dan Mashal <dan.mashal@fedoraproject.org> 1.4.0-8
- Add disable-update-mimedb to configure flag and update files section

* Wed Oct 03 2012 Dan Mashal <dan.mashal@fedoraproject.org> 1.4.0-7
- Remove noreplace bit for schemas 
- Remove ownership of XMLnamespaces and aliases folders
- Remove desktop-file-utils from post and postun requires field
- Add mate-conf to post requires field

* Tue Oct 02 2012 Dan Mashal <dan.mashal@fedoraproject.org> 1.4.0-6
- Remove unnecessary explicit libexecdir configure flag, remove explicit requires field

* Tue Oct 02 2012 Dan Mashal <dan.mashal@fedoraproject.org> 1.4.0-5
- Fix spelling error on schema install.

* Sun Sep 30 2012 Dan Mashal <dan.mashal@fedoraproject.org> 1.4.0-4
- Update BR and remove about-me

* Wed Sep 26 2012 Dan Mashal <dan.mashal@fedoraproject.org> 1.4.0-3
- Add excludes to files section as per package review.

* Tue Sep 25 2012 Dan Mashal <dan.mashal@fedoraproject.org> 1.4.0-2
- Update files section as per review, update build requires.

* Sat Sep 01 2012 Dan Mashal <dan.mashal@fedoraproject.org> 1.4.0-1
- Initial build