Blob Blame History Raw
Name:           pyee
Version:        3.0.0
Release:        1%{?dist}
Summary:        A port of node.js's EventEmitter to python 
License:        MIT
URL:            https://pypi.python.org/pypi/pyee
Source0:        https://github.com/jfhbrook/%{name}/archive/%{version}.tar.gz

BuildArch: noarch

BuildRequires:  python2-devel
BuildRequires:  python2-setuptools
BuildRequires:  python2-flake8
BuildRequires:  python2-mock
BuildRequires:  python2-sphinx
BuildRequires:  python2-tox
BuildRequires:  python2-twine
BuildRequires:  python2-twisted
BuildRequires:  python2-pytest
BuildRequires:  python2-pytest-runner

BuildRequires:  python3-devel
BuildRequires:  python3-setuptools
BuildRequires:  python3-flake8
BuildRequires:  python3-mock
BuildRequires:  python3-sphinx
BuildRequires:  python3-tox
BuildRequires:  python3-twine
BuildRequires:  python3-twisted
BuildRequires:  python3-pytest
BuildRequires:  python3-pytest-runner

%description
A port of node.js's EventEmitter to python.

%package -n python2-ee
Summary:        A port of node.js's EventEmitter to python
%{?python_provide:%python_provide python2-ee}

%description -n python2-ee
A port of node.js's EventEmitter to python.

%package -n python3-ee
Summary:        A port of node.js's EventEmitter to python
%{?python_provide:%python_provide python3-ee}

%description -n python3-ee
A port of node.js's EventEmitter to python.

%prep
%setup -q

%build
%py2_build
%py3_build

%install
%py2_install
%py3_install

%check
%{__python2} setup.py test
%{__python3} setup.py test

%files -n python2-ee
%license LICENSE
%{python_sitelib}/*

%files -n python3-ee
%license LICENSE
%{python3_sitelib}/*

%changelog
* Sun Feb  5 2017 Peter Robinson <pbrobinson@fedoraproject.org> 3.0.0-1
- initial packaging