Blob Blame History Raw
# Generated by rust2rpm 26
# * test sources are not included in published crates
%bcond_with check
%global debug_package %{nil}

# prevent executables from being installed
%global cargo_install_bin 0

%global crate clap

Name:           rust-clap
Version:        4.5.3
Release:        %autorelease
Summary:        Simple to use, efficient, and full-featured Command Line Argument Parser

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/clap
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 26

%global _description %{expand:
A simple to use, efficient, and full-featured Command Line Argument
Parser.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+cargo-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+cargo-devel %{_description}

This package contains library source intended for building other packages which
use the "cargo" feature of the "%{crate}" crate.

%files       -n %{name}+cargo-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+color-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+color-devel %{_description}

This package contains library source intended for building other packages which
use the "color" feature of the "%{crate}" crate.

%files       -n %{name}+color-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+debug-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+debug-devel %{_description}

This package contains library source intended for building other packages which
use the "debug" feature of the "%{crate}" crate.

%files       -n %{name}+debug-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+deprecated-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+deprecated-devel %{_description}

This package contains library source intended for building other packages which
use the "deprecated" feature of the "%{crate}" crate.

%files       -n %{name}+deprecated-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+derive-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+derive-devel %{_description}

This package contains library source intended for building other packages which
use the "derive" feature of the "%{crate}" crate.

%files       -n %{name}+derive-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+env-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+env-devel %{_description}

This package contains library source intended for building other packages which
use the "env" feature of the "%{crate}" crate.

%files       -n %{name}+env-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+error-context-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+error-context-devel %{_description}

This package contains library source intended for building other packages which
use the "error-context" feature of the "%{crate}" crate.

%files       -n %{name}+error-context-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+help-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+help-devel %{_description}

This package contains library source intended for building other packages which
use the "help" feature of the "%{crate}" crate.

%files       -n %{name}+help-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+string-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+string-devel %{_description}

This package contains library source intended for building other packages which
use the "string" feature of the "%{crate}" crate.

%files       -n %{name}+string-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+suggestions-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+suggestions-devel %{_description}

This package contains library source intended for building other packages which
use the "suggestions" feature of the "%{crate}" crate.

%files       -n %{name}+suggestions-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unicode-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unicode-devel %{_description}

This package contains library source intended for building other packages which
use the "unicode" feature of the "%{crate}" crate.

%files       -n %{name}+unicode-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unstable-doc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-doc-devel %{_description}

This package contains library source intended for building other packages which
use the "unstable-doc" feature of the "%{crate}" crate.

%files       -n %{name}+unstable-doc-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unstable-styles-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-styles-devel %{_description}

This package contains library source intended for building other packages which
use the "unstable-styles" feature of the "%{crate}" crate.

%files       -n %{name}+unstable-styles-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unstable-v5-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-v5-devel %{_description}

This package contains library source intended for building other packages which
use the "unstable-v5" feature of the "%{crate}" crate.

%files       -n %{name}+unstable-v5-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+usage-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+usage-devel %{_description}

This package contains library source intended for building other packages which
use the "usage" feature of the "%{crate}" crate.

%files       -n %{name}+usage-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+wrap_help-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+wrap_help-devel %{_description}

This package contains library source intended for building other packages which
use the "wrap_help" feature of the "%{crate}" crate.

%files       -n %{name}+wrap_help-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog