Blob Blame History Raw
# Generated by rust2rpm 22
# * missing dev-dependencies: snapbox, trycmd
%bcond_with check
%global debug_package %{nil}

%global crate clap

Name:           rust-clap
Version:        3.2.16
Release:        %autorelease
Summary:        Simple to use, efficient, and full-featured Command Line Argument Parser

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/clap
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
# * disable building a test fixture binary
Patch:          clap-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Simple to use, efficient, and full-featured Command Line Argument Parser.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+atty-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+atty-devel %{_description}

This package contains library source intended for building other packages which
use the "atty" feature of the "%{crate}" crate.

%files       -n %{name}+atty-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+backtrace-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+backtrace-devel %{_description}

This package contains library source intended for building other packages which
use the "backtrace" feature of the "%{crate}" crate.

%files       -n %{name}+backtrace-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+cargo-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+cargo-devel %{_description}

This package contains library source intended for building other packages which
use the "cargo" feature of the "%{crate}" crate.

%files       -n %{name}+cargo-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+clap_derive-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+clap_derive-devel %{_description}

This package contains library source intended for building other packages which
use the "clap_derive" feature of the "%{crate}" crate.

%files       -n %{name}+clap_derive-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+color-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+color-devel %{_description}

This package contains library source intended for building other packages which
use the "color" feature of the "%{crate}" crate.

%files       -n %{name}+color-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+debug-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+debug-devel %{_description}

This package contains library source intended for building other packages which
use the "debug" feature of the "%{crate}" crate.

%files       -n %{name}+debug-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+deprecated-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+deprecated-devel %{_description}

This package contains library source intended for building other packages which
use the "deprecated" feature of the "%{crate}" crate.

%files       -n %{name}+deprecated-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+derive-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+derive-devel %{_description}

This package contains library source intended for building other packages which
use the "derive" feature of the "%{crate}" crate.

%files       -n %{name}+derive-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+env-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+env-devel %{_description}

This package contains library source intended for building other packages which
use the "env" feature of the "%{crate}" crate.

%files       -n %{name}+env-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+once_cell-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+once_cell-devel %{_description}

This package contains library source intended for building other packages which
use the "once_cell" feature of the "%{crate}" crate.

%files       -n %{name}+once_cell-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+regex-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+regex-devel %{_description}

This package contains library source intended for building other packages which
use the "regex" feature of the "%{crate}" crate.

%files       -n %{name}+regex-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+strsim-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+strsim-devel %{_description}

This package contains library source intended for building other packages which
use the "strsim" feature of the "%{crate}" crate.

%files       -n %{name}+strsim-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+suggestions-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+suggestions-devel %{_description}

This package contains library source intended for building other packages which
use the "suggestions" feature of the "%{crate}" crate.

%files       -n %{name}+suggestions-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+termcolor-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+termcolor-devel %{_description}

This package contains library source intended for building other packages which
use the "termcolor" feature of the "%{crate}" crate.

%files       -n %{name}+termcolor-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+terminal_size-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+terminal_size-devel %{_description}

This package contains library source intended for building other packages which
use the "terminal_size" feature of the "%{crate}" crate.

%files       -n %{name}+terminal_size-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unicase-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unicase-devel %{_description}

This package contains library source intended for building other packages which
use the "unicase" feature of the "%{crate}" crate.

%files       -n %{name}+unicase-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unicode-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unicode-devel %{_description}

This package contains library source intended for building other packages which
use the "unicode" feature of the "%{crate}" crate.

%files       -n %{name}+unicode-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unstable-doc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-doc-devel %{_description}

This package contains library source intended for building other packages which
use the "unstable-doc" feature of the "%{crate}" crate.

%files       -n %{name}+unstable-doc-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unstable-grouped-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-grouped-devel %{_description}

This package contains library source intended for building other packages which
use the "unstable-grouped" feature of the "%{crate}" crate.

%files       -n %{name}+unstable-grouped-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unstable-replace-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-replace-devel %{_description}

This package contains library source intended for building other packages which
use the "unstable-replace" feature of the "%{crate}" crate.

%files       -n %{name}+unstable-replace-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unstable-v4-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-v4-devel %{_description}

This package contains library source intended for building other packages which
use the "unstable-v4" feature of the "%{crate}" crate.

%files       -n %{name}+unstable-v4-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+wrap_help-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+wrap_help-devel %{_description}

This package contains library source intended for building other packages which
use the "wrap_help" feature of the "%{crate}" crate.

%files       -n %{name}+wrap_help-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+yaml-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+yaml-devel %{_description}

This package contains library source intended for building other packages which
use the "yaml" feature of the "%{crate}" crate.

%files       -n %{name}+yaml-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+yaml-rust-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+yaml-rust-devel %{_description}

This package contains library source intended for building other packages which
use the "yaml-rust" feature of the "%{crate}" crate.

%files       -n %{name}+yaml-rust-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog