Blob Blame History Raw
# Generated by rust2rpm 22
%bcond_without check
%global debug_package %{nil}

%global crate clap_derive

Name:           rust-clap_derive
Version:        3.2.18
Release:        %autorelease
Summary:        Parse command line argument by defining a struct, derive crate

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/clap_derive
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Parse command line argument by defining a struct, derive crate.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+debug-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+debug-devel %{_description}

This package contains library source intended for building other packages which
use the "debug" feature of the "%{crate}" crate.

%files       -n %{name}+debug-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+deprecated-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+deprecated-devel %{_description}

This package contains library source intended for building other packages which
use the "deprecated" feature of the "%{crate}" crate.

%files       -n %{name}+deprecated-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+raw-deprecated-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+raw-deprecated-devel %{_description}

This package contains library source intended for building other packages which
use the "raw-deprecated" feature of the "%{crate}" crate.

%files       -n %{name}+raw-deprecated-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unstable-v4-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-v4-devel %{_description}

This package contains library source intended for building other packages which
use the "unstable-v4" feature of the "%{crate}" crate.

%files       -n %{name}+unstable-v4-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog