Blob Blame History Raw
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}

%global crate diesel_derives

Name:           rust-diesel_derives
Version:        2.1.4
Release:        %autorelease
Summary:        You should not use this crate directly, it is internal to Diesel

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/diesel_derives
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
You should not use this crate directly, it is internal to Diesel.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+128-column-tables-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+128-column-tables-devel %{_description}

This package contains library source intended for building other packages which
use the "128-column-tables" feature of the "%{crate}" crate.

%files       -n %{name}+128-column-tables-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+32-column-tables-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+32-column-tables-devel %{_description}

This package contains library source intended for building other packages which
use the "32-column-tables" feature of the "%{crate}" crate.

%files       -n %{name}+32-column-tables-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+64-column-tables-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+64-column-tables-devel %{_description}

This package contains library source intended for building other packages which
use the "64-column-tables" feature of the "%{crate}" crate.

%files       -n %{name}+64-column-tables-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+chrono-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+chrono-devel %{_description}

This package contains library source intended for building other packages which
use the "chrono" feature of the "%{crate}" crate.

%files       -n %{name}+chrono-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+postgres-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+postgres-devel %{_description}

This package contains library source intended for building other packages which
use the "postgres" feature of the "%{crate}" crate.

%files       -n %{name}+postgres-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+r2d2-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+r2d2-devel %{_description}

This package contains library source intended for building other packages which
use the "r2d2" feature of the "%{crate}" crate.

%files       -n %{name}+r2d2-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+sqlite-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+sqlite-devel %{_description}

This package contains library source intended for building other packages which
use the "sqlite" feature of the "%{crate}" crate.

%files       -n %{name}+sqlite-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+time-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+time-devel %{_description}

This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.

%files       -n %{name}+time-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+with-deprecated-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+with-deprecated-devel %{_description}

This package contains library source intended for building other packages which
use the "with-deprecated" feature of the "%{crate}" crate.

%files       -n %{name}+with-deprecated-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+without-deprecated-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+without-deprecated-devel %{_description}

This package contains library source intended for building other packages which
use the "without-deprecated" feature of the "%{crate}" crate.

%files       -n %{name}+without-deprecated-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
# * doctests can only be run in-tree
%cargo_test -- --lib
%endif

%changelog
%autochangelog