Blob Blame History Raw
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}

%global crate lddtree

Name:           rust-lddtree
Version:        0.3.4
Release:        %autorelease
Summary:        Read the ELF dependency tree

License:        MIT
URL:            https://crates.io/crates/lddtree
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
# * skip building unused executable
# * exclude tests and binary test fixtures from installed files
Patch:          lddtree-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Read the ELF dependency tree.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%ifarch aarch64
# * skip test that doesn't work on aarch64
%cargo_test -- -- --skip test_lddtree
%else
%cargo_test
%endif
%endif

%changelog
%autochangelog