Blob Blame History Raw
# Generated by rust2rpm 26
# * tests can not be run when built in "release" mode
%bcond_with check
%global debug_package %{nil}

%global crate new_debug_unreachable

Name:           rust-new_debug_unreachable
Version:        1.0.6
Release:        %autorelease
Summary:        Panic in debug, intrinsics::unreachable() in release

License:        MIT
URL:            https://crates.io/crates/new_debug_unreachable
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Panic in debug, intrinsics::unreachable() in release (fork of
debug_unreachable).}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog