Blob Blame History Raw
# Generated by rust2rpm 25
# * test sources are not included in published crates
%bcond_with check
%global debug_package %{nil}

%global crate num_threads

Name:           rust-num_threads
Version:        0.1.7
Release:        %autorelease
Summary:        Determine the number of running threads for the current process

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/num_threads
Source:         %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch:          num_threads-fix-metadata-auto.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
A minimal library that determines the number of running threads for the
current process.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-Apache
%license %{crate_instdir}/LICENSE-MIT
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog