Blob Blame History Raw
# Generated by rust2rpm
# * Tests are run in infrastructure
%bcond_with check
%global debug_package %{nil}

%global crate parking_lot

Name:           rust-%{crate}
Version:        0.6.4
Release:        2%{?dist}
Summary:        Compact and efficient implementations of standard synchronization primitives

# Upstream license specification: Apache-2.0/MIT
License:        ASL 2.0 or MIT
URL:            https://crates.io/crates/parking_lot
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * No nightly
# * No deadlock_detection in parking_lot_core
Patch0:         parking_lot-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
# [dependencies]
BuildRequires:  (crate(lock_api) >= 0.1.0 with crate(lock_api) < 0.2.0)
BuildRequires:  (crate(parking_lot_core) >= 0.3.0 with crate(parking_lot_core) < 0.4.0)
%if %{with check}
# [dev-dependencies]
BuildRequires:  (crate(rand) >= 0.5.0 with crate(rand) < 0.6.0)
%endif

%description
%{summary}.

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel
More compact and efficient implementations of the standard synchronization
primitives.

This package contains library source intended for building other packages
which use %{crate} from crates.io.

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%files          devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml

%changelog
* Sun Oct 07 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.4-2
- Run tests in infrastructure

* Mon Sep 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.4-1
- Initial package