Blob Blame History Raw
# Generated by rust2rpm 26
%bcond_without check

%global crate pulldown-cmark

Name:           rust-pulldown-cmark
Version:        0.10.3
Release:        %autorelease
Summary:        Pull parser for CommonMark

License:        MIT
URL:            https://crates.io/crates/pulldown-cmark
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency
Patch:          pulldown-cmark-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
A pull parser for CommonMark.}

%description %{_description}

%package     -n %{crate}
Summary:        %{summary}
# MIT
# MIT OR Apache-2.0
# Unlicense OR MIT
License:        MIT AND (MIT OR Apache-2.0) AND (Unlicense OR MIT)
# LICENSE.dependencies contains a full license breakdown

%description -n %{crate} %{_description}

%files       -n %{crate}
%license LICENSE
%license LICENSE.dependencies
%doc README.md
%{_bindir}/pulldown-cmark

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gen-tests-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gen-tests-devel %{_description}

This package contains library source intended for building other packages which
use the "gen-tests" feature of the "%{crate}" crate.

%files       -n %{name}+gen-tests-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+getopts-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+getopts-devel %{_description}

This package contains library source intended for building other packages which
use the "getopts" feature of the "%{crate}" crate.

%files       -n %{name}+getopts-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+html-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+html-devel %{_description}

This package contains library source intended for building other packages which
use the "html" feature of the "%{crate}" crate.

%files       -n %{name}+html-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+pulldown-cmark-escape-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+pulldown-cmark-escape-devel %{_description}

This package contains library source intended for building other packages which
use the "pulldown-cmark-escape" feature of the "%{crate}" crate.

%files       -n %{name}+pulldown-cmark-escape-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serde-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde-devel %{_description}

This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.

%files       -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+simd-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+simd-devel %{_description}

This package contains library source intended for building other packages which
use the "simd" feature of the "%{crate}" crate.

%files       -n %{name}+simd-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build
%{cargo_license_summary}
%{cargo_license} > LICENSE.dependencies

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog