Blob Blame History Raw
# Generated by rust2rpm 25
# * tests no longer compile with recent versions of Rust
%bcond_with check
%global debug_package %{nil}

%global crate rustc-serialize

Name:           rust-rustc-serialize
Version:        0.3.25
Release:        %autorelease
Summary:        Generic serialization/deserialization support

# Upstream license specification: MIT/Apache-2.0
License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/rustc-serialize
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
# * exclude CI configuration files
Patch:          rustc-serialize-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Generic serialization/deserialization support corresponding to the
`derive(RustcEncodable, RustcDecodable)` mode in the compiler. Also
includes support for hex, base64, and json encoding and decoding. This
crate is deprecated in favor of serde.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch
Provides:       deprecated()

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog