Blob Blame History Raw
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}

%global crate ttf-parser

Name:           rust-ttf-parser
Version:        0.18.1
Release:        %autorelease
Summary:        High-level, safe, zero-allocation TrueType font parser

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/ttf-parser
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
# * exclude unwanted files
# * remove unused pico-args dev-dependency
Patch:          ttf-parser-fix-metadata.diff

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
A high-level, safe, zero-allocation TrueType font parser.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+apple-layout-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+apple-layout-devel %{_description}

This package contains library source intended for building other packages which
use the "apple-layout" feature of the "%{crate}" crate.

%files       -n %{name}+apple-layout-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+glyph-names-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+glyph-names-devel %{_description}

This package contains library source intended for building other packages which
use the "glyph-names" feature of the "%{crate}" crate.

%files       -n %{name}+glyph-names-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gvar-alloc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gvar-alloc-devel %{_description}

This package contains library source intended for building other packages which
use the "gvar-alloc" feature of the "%{crate}" crate.

%files       -n %{name}+gvar-alloc-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+opentype-layout-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+opentype-layout-devel %{_description}

This package contains library source intended for building other packages which
use the "opentype-layout" feature of the "%{crate}" crate.

%files       -n %{name}+opentype-layout-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+variable-fonts-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+variable-fonts-devel %{_description}

This package contains library source intended for building other packages which
use the "variable-fonts" feature of the "%{crate}" crate.

%files       -n %{name}+variable-fonts-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
# only unit tests are included in published crates
%cargo_test -- --lib
%cargo_test -- --doc
%endif

%changelog
%autochangelog