Blob Blame History Raw
# Generated by rust2rpm 26
# * Undeclared dependencies (workspace paths removed by cargo publish):
#   wasm_encoder, wast, wat
%bcond_with check
%global debug_package %{nil}

%global crate wasmparser

Name:           rust-wasmparser
Version:        0.201.0
Release:        %autorelease
Summary:        Simple event-driven library for parsing WebAssembly binary files

License:        Apache-2.0 WITH LLVM-exception
URL:            https://crates.io/crates/wasmparser
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
A simple event-driven library for parsing WebAssembly binary files.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog