Blob Blame History Raw
%global _hardened_build 1
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}

Name:           wesnoth
Version:        1.10.6
Release:        7%{?dist}
Summary:        Turn-based strategy game with a fantasy theme

Group:          Amusements/Games
License:        GPLv2+
URL:            http://www.wesnoth.org
Source0:        http://www.%{name}.org/files/%{name}-%{version}.tar.bz2
Source1:        wesnothd.service
Source2:        %{name}.sysconfig
Patch0:         %{name}-1.2.8-gcc43.patch
#Patch1:         wesnoth-1.5.11-remove-ogg-test.patch
#Patch2:        wesnoth-1.6.4-fribidi.patch
#Patch3:         wesnoth-1.8.3-boost-iostreams.patch
#Patch4:		wesnoth-1.8.5-cstddef.patch
#Patch5:		wesnoth-1.8.6-boost-foreach.patch
#Patch6:		wesnoth-libpng15.patch
Patch7:		wesnoth-1.10.6-crash.patch

Requires:       wesnoth-data = %{version}
BuildRequires:  SDL_image-devel
BuildRequires:  SDL_mixer-devel
BuildRequires:  SDL_net-devel
BuildRequires:  SDL_ttf-devel
BuildRequires:  freetype-devel
BuildRequires:  libpng-devel
BuildRequires:  fribidi-devel
BuildRequires:  python-devel
BuildRequires:  desktop-file-utils
BuildRequires:  gettext
BuildRequires:  boost-devel
BuildRequires:  pango-devel
BuildRequires:  lua-devel
BuildRequires:  scons
# Drop these when ogg test patch is removed.
#BuildRequires:  autoconf
#BuildRequires:  automake

%description
The Battle for Wesnoth is a turn-based strategy game with a fantasy theme.

Build up a great army, gradually turning raw recruits into hardened
veterans. In later games, recall your toughest warriors and form a deadly
host against whom none can stand. Choose units from a large pool of
specialists, and hand-pick a force with the right strengths to fight well
on different terrains against all manner of opposition.

Fight to regain the throne of Wesnoth, of which you are the legitimate
heir, or use your dread power over the Undead to dominate the land of
mortals, or lead your glorious Orcish tribe to victory against the humans
who dared despoil your lands. Wesnoth has many different sagas waiting to
be played out. You can create your own custom units, and write your own
scenarios--or even full-blown campaigns. You can also challenge your
friends--or strangers--and fight multi-player epic fantasy battles.

##%ifnarch noarch
%package server
Summary:        %{summary}
Group:          Amusements/Games
Requires:       %{name} = %{version}-%{release}
#Requires(post): /sbin/chkconfig
#Requires(preun):/sbin/chkconfig
Requires(pre):  /usr/sbin/useradd
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
Requires(post): systemd-sysv


%description server
This package contains the binaries for running a Wesnoth server
for multi-player games.


%package tools
Summary:        %{summary}
Group:          Amusements/Games
Requires:       %{name} = %{version}-%{release}


%description tools
This package contains the game editor and development tools.

##%else
%package data
Summary:        %{summary}
Group:          Amusements/Games
Requires:       %{name} = %{version}
BuildArch:      noarch

%description data
This package contains the data files for Wesnoth.
##%endif

%prep
%setup -qn wesnoth-%{version}
%patch0 -p1 -b .gcc43
#%patch1 -p0
#%patch2 -p0
#%patch3 -p1 -b .boost-iostreams
#%patch4 -p0 -b .cstddef
#%patch5 -p1 -b .boost-foreach
#%patch6 -p0 -b .libpng
%patch7 -p0 -b .crash

%build
# Cannot use configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
export CFLAGS="$RPM_OPT_FLAGS"
export CXXFLAGS="$RPM_OPT_FLAGS"
export LDFLAGS="%{?__global_ldflags}"
#./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --sharedstatedir=%{_sharedstatedir}  --mandir=%{_mandir} --infodir=%{_infodir} \
#    --disable-dependency-tracking \
#    --with-localedir=%{_datadir}/locale \
#    --enable-editor \
#    --enable-tools \
#    --enable-server \
#    --enable-python \
#    --with-fifodir=/var/run/wesnothd \
#    --with-server-uid=$(id -u) \
#    --with-server-gid=$(id -g) \
#    --disable-strict-compilation

##%%cmake . -DCMAKE_INSTALL_PREFIX=${RPM_BUILD_ROOT}%{_prefix} -DDATAROOTDIR=%{_datadir} -DBINDIR=%{_bindir} -DENABLE_TOOLS=ON -DSERVER_UID=$(id -u) -DSERVER_GID=$(id -g) -DCMAKE_INSTALL_PREFIX=%{RPM_BUILD_ROOT} -DENABLE_NLS=ON
%ifnarch noarch
#make %{?_smp_mflags}
scons all prefix=/usr
%endif

%install
#make install
mkdir -p $RPM_BUILD_ROOT/%{_bindir}
mkdir -p $RPM_BUILD_ROOT/%{_sbindir}
for i in cutter exploder wesnoth; do
	cp -p $i $RPM_BUILD_ROOT/%{_bindir}/
done
cp wesnothd $RPM_BUILD_ROOT/%{_sbindir}/
pushd data
pushd tools
for i in wesnoth_addon_manager wml*; do
	cp -p $i $RPM_BUILD_ROOT/%{_bindir}/
done
popd
popd

#%ifarch noarch
### Data Files and Desktop Files
#make install-data DESTDIR=${RPM_BUILD_ROOT}
#Python modules for tools
mkdir -p $RPM_BUILD_ROOT%{python_sitelib} 
mv data/tools/wesnoth $RPM_BUILD_ROOT%{python_sitelib} 

mkdir -p $RPM_BUILD_ROOT/%{_datadir}/wesnoth
for i in data fonts icons images sounds; do
	cp -pr $i $RPM_BUILD_ROOT/%{_datadir}/wesnoth/
done
rm -rf $RPM_BUILD_ROOT%{_datadir}/applications

desktop-file-install --dir $RPM_BUILD_ROOT/%{_datadir}/applications \
                     --mode="0644" \
                     --remove-key="Version" \
                     icons/%{name}.desktop

# add icon for menus
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps
ln -sf ../wesnoth/icons/%{name}-icon.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps
ln -sf ../wesnoth/icons/%{name}_editor-icon.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps

# Wesnoth ships its own fonts, replace with Fedora packaged versions
rm -f $RPM_BUILD_ROOT/%{_datadir}/fonts/*
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/fonts
# dejavu-fonts
ln -s /usr/share/fonts/dejavu/DejaVuSans.ttf $RPM_BUILD_ROOT/%{_datadir}/fonts/DejaVuSans.ttf
# sazanami-fonts-gothic
ln -s /usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf $RPM_BUILD_ROOT/%{_datadir}/fonts/sazanami-gothic.ttf
# wqy-zenhei-fonts
ln -s /usr/share/fonts/wqy-zenhei/wqy-zenhei.ttc $RPM_BUILD_ROOT/%{_datadir}/fonts/wqy-zenhei.ttc

#So find_lang will work. . .
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/locale
cp -pr translations/* $RPM_BUILD_ROOT/%{_datadir}/locale/

#So wesnoth can still find the translations. . .
ln -s %{_datadir}/locale/ $RPM_BUILD_ROOT/%{_datadir}/wesnoth/translations

mkdir -p $RPM_BUILD_ROOT/%{_mandir}
pushd doc
pushd man

    rm CMakeLists.txt

    for d in $(dirname */*.6 | sort -u); do
        pushd $d
            mkdir man6
            mv *.6 man6
        popd
    done

    mkdir man6
    mv *.6 man6

popd
popd

cp -pr doc/man/* $RPM_BUILD_ROOT/%{_mandir}
find $RPM_BUILD_ROOT/%{_mandir} -name '*.6'  | xargs gzip

%find_lang %{name}*.\*

#%else
### Binaries and Config Files
#make install-exec DESTDIR=${RPM_BUILD_ROOT}

desktop-file-install --dir $RPM_BUILD_ROOT/%{_datadir}/applications \
                     --mode="0644" --vendor fedora \
                     --remove-key="Version" \
                     icons/%{name}_editor.desktop

# arrange server package files
mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
#mv ${RPM_BUILD_ROOT}%{_bindir}/wesnothd ${RPM_BUILD_ROOT}%{_sbindir}
mkdir -p ${RPM_BUILD_ROOT}/var/run/wesnothd
touch ${RPM_BUILD_ROOT}/var/run/wesnothd/socket
install -Dpm 755 %{SOURCE1} \
    $RPM_BUILD_ROOT%{_unitdir}/wesnothd.service
install -Dpm 644 %{SOURCE2} \
    $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/wesnoth

#%endif

### Cleanup Stuff
rm -f $RPM_BUILD_ROOT/usr/share/wesnoth/icons/*.desktop

find $RPM_BUILD_ROOT -name ".cvs*" | xargs rm -f
find $RPM_BUILD_ROOT -name "CVS" | xargs rm -rf
find $RPM_BUILD_ROOT/ -name 'Makefile*' |xargs rm -f

rm -rf $RPM_BUILD_ROOT/usr/share/doc/wesnoth/
rm -f $RPM_BUILD_ROOT/usr/share/icons/wesnoth-icon.png
rm -f $RPM_BUILD_ROOT/usr/share/icons/wesnoth_editor-icon.png
rm -f $RPM_BUILD_ROOT/usr/share/applications/fedora-wesnoth_editor.desktop


#%ifarch noarch
%post
touch --no-create %{_datadir}/icons/hicolor || :
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
fi

%postun
touch --no-create %{_datadir}/icons/hicolor || :
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
fi
#%endif

#%ifnarch noarch
%pre server
/usr/sbin/useradd -c "Wesnoth server" -s /sbin/nologin \
          -r -d /var/run/wesnothd wesnothd 2> /dev/null || :


%post server
#/sbin/chkconfig --add wesnothd
#if [ $1 -gt 1 ]; then
#    %%{_initrddir}/wesnothd try-restart >/dev/null || :
#fi
if [ $1 -eq 1 ] ; then 
    # Initial installation 
    /bin/systemctl daemon-reload >/dev/null 2>&1 || :
fi



%preun server
#if [ $1 -eq 0 ]; then
#    %%{_initrddir}/wesnothd stop >/dev/null 2>&1 || :
#    /sbin/chkconfig --del wesnothd
#fi
if [ $1 -eq 0 ] ; then
    # Package removal, not upgrade
    /bin/systemctl --no-reload disable wesnothd.service > /dev/null 2>&1 || :
    /bin/systemctl stop wesnothd.service > /dev/null 2>&1 || :
fi

%postun server
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
if [ $1 -ge 1 ] ; then
    # Package upgrade, not uninstall
    /bin/systemctl try-restart wesnothd.service >/dev/null 2>&1 || :
fi


#%endif

%triggerun -- wesnoth-server < 1.10-2
# Save the current service runlevel info
# User must manually run systemd-sysv-convert --apply wesnothd
# to migrate them to systemd targets
/usr/bin/systemd-sysv-convert --save wesnothd >/dev/null 2>&1 ||:

# Run these because the SysV package being removed won't do them
/sbin/chkconfig --del wesnothd >/dev/null 2>&1 || :
/bin/systemctl try-restart wesnothd.service >/dev/null 2>&1 || :


#%ifnarch noarch
%files
%doc COPYING changelog README copyright doc/manual/
%{_bindir}/%{name}

%files tools
#%{_bindir}/wesnoth_editor
%{_bindir}/wesnoth_addon_manager
%{_bindir}/exploder
%{_bindir}/cutter
%{_bindir}/wml*
#%{_datadir}/applications/wesnoth_editor.desktop

%files server
#%%config %%{_initrddir}/wesnothd
%{_unitdir}/wesnothd.service
%config(noreplace) %{_sysconfdir}/sysconfig/wesnoth
%{_sbindir}/wesnothd
%attr(0700,wesnothd,wesnothd) %dir /var/run/wesnothd/
%ghost /var/run/wesnothd/socket
#%endif

#%ifarch noarch
%files data -f %{name}*.*.lang
%{_datadir}/%{name}
%{_datadir}/applications/wesnoth.desktop
%{_datadir}/pixmaps/*
%{_datadir}/fonts/*
%{python_sitelib}/wesnoth
%{_mandir}/man6/*
%{_mandir}/*/man6/*

#%endif

%changelog
* Thu Aug 01 2013 Jon Ciesla <limburgher@gmail.com> - 1.10.6-7
- Another man page fix attempt.

* Tue Jul 30 2013 Jon Ciesla <limburgher@gmail.com> - 1.10.6-6
- Fix man page ownership, with comments from BZ 905379.

* Sat Jul 27 2013 pmachata@redhat.com - 1.10.6-5
- Rebuild for boost 1.54.0

* Thu Jul 25 2013 Jon Ciesla <limburgher@gmail.com> - 1.10.6-4
- Fix man page ownership, BZ 958465.

* Thu Apr 25 2013 Jon Ciesla <limburgher@gmail.com> - 1.10.6-3
- Add PIE, BZ 955196.

* Wed Apr 24 2013 Jon Ciesla <limburgher@gmail.com> - 1.10.6-2
- Fix for crash, BZ 953327.

* Thu Mar 28 2013 Jon Ciesla <limburgher@gmail.com> - 1.10.6-1
- New upstream maintainance release.

* Mon Feb 11 2013 Parag Nemade <paragn AT fedoraproject DOT org> - 1.10.5-5
- Remove vendor tag from desktop file as per https://fedorahosted.org/fesco/ticket/1077
- Cleanup spec as per recently changed packaging guidelines

* Sat Feb 09 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.10.5-4
- Rebuild for Boost-1.53.0

* Fri Feb 01 2013 Jon Ciesla <limburgher@gmail.com> - 1.10.5-3
- Fin man page locations, BZ 905379.

* Tue Nov 20 2012 Jon Ciesla <limburgher@gmail.com> - 1.10.5-2
- Switched from cmake to scons to fix build issue.

* Tue Nov 20 2012 Jon Ciesla <limburgher@gmail.com> - 1.10.5-1
- New upstream maintainance release.

* Tue Aug 28 2012 Jon Ciesla <limburgher@gmail.com> - 1.10.4-1
- New upstream maintainance release.

* Fri Jul 27 2012 Jon Ciesla <limburgher@gmail.com> - 1.10.3-5
- Fix for translation issue, BZ 840916.

* Thu Jul 26 2012 Jon Ciesla <limburgher@gmail.com> - 1.10.3-4
- Rebuild for boost 1.50.

* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

* Mon May 21 2012 Jon Ciesla <limburgher@gmail.com> - 1.10.3-1
- New upstream maintainance release.

* Fri Apr 13 2012 Jon Ciesla <limburgher@gmail.com> - 1.10.2-2
- Added hardened build.

* Mon Apr 09 2012 Jon Ciesla <limburgher@gmail.com> - 1.10.2-1
- New upstream maintainance release.

* Mon Feb 27 2012 Jon Ciesla <limburgher@gmail.com> - 1.10.1-1
- New upstream maintainance release.

* Tue Jan 31 2012 Jon Ciesla <limburgher@gmail.com> - 1.10-2
- Migrate to systemd, BZ 661241.
- Placed python modules.

* Sun Jan 29 2012 Jon Ciesla <limburgher@gmail.com> - 1.10-1
- New upstream, 1.10 final.

* Tue Jan 10 2012 Jon Ciesla <limburgher@gmail.com> - 1.9.14-1
- New upstream, 1.10-rc1.

* Wed Dec 21 2011 Jon Ciesla <limburgher@gmail.com> - 1.9.13-1
- New upstream.

* Thu Dec 08 2011 Jon Ciesla <limb@jcomserv.net> - 1.9.12-1
- Update to latest development release.
- Dropped ogg-test patch.
- Dropped cstddef patch, upstreamed.
- Moved from autotools to cmake build system.
- Could not get cmake install to work, did it my way.

* Sun Nov 20 2011 Bruno Wolff III <bruno@wolff.to> - 1.8.6-5
- Rebuild for boost soname bump

* Sun Nov 06 2011 Bruno Wolff III <bruno@wolff.to> - 1.8.6-4
- Include zlib.h since libpng 1.5 no longer does
- Replace some macros for null values with NULL no longer defined by png.h

* Thu Jul 21 2011 Jon Ciesla <limb@jcomserv.net> - 1.8.6-3
- Rebuild for new boost.
- Patch for foreach change, BZ 724818.

* Fri Jun 17 2011 Jon Ciesla <limb@jcomserv.net> - 1.8.6-2
- Bump and rebuild for BZ 712251.

* Fri May 13 2011 Jon Ciesla <limb@jcomserv.net> - 1.8.6-1
- Upstream maintenance release.

* Fri Apr 08 2011 Bruno Wolff III <bruno@wolff.to> - 1.8.5-5
- Rebuild for boost 1.46.1 soname bump in rawhide

* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.5-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

* Sun Feb 06 2011 Thomas Spura <tomspur@fedoraproject.org> - 1.8.5-3
- rebuild for new boost

* Tue Oct 05 2010 Jon Ciesla <limb@jcomserv.net> - 1.8.5-2
- Font symlink correction, BZ 604905.

* Thu Sep 30 2010 Jon Ciesla <limb@jcomserv.net> - 1.8.5-1
- Upstream maintenance release.
- Boost iostreams patch upstreamed.

* Tue Aug 10 2010 Jon Ciesla <limb@jcomserv.net> - 1.8.4-1
- Upstream maintenance release.

* Thu Aug  5 2010 Michael Schwendt <mschwendt@fedoraproject.org> - 1.8.3-3
- Fix boost.m4 configure check.

* Wed Jul 28 2010 Jon Ciesla <limb@jcomserv.net> - 1.8.3-2
- Rebuild for new Boost.

* Tue Jul 06 2010 Jon Ciesla <limb@jcomserv.net> - 1.8.3-1
- Upstream maintenance release.

* Mon Jun 07 2010 Jon Ciesla <limb@jcomserv.net> - 1.8.2-1
- Upstream maintenance release.

* Thu May 13 2010 Jon Ciesla <limb@jcomserv.net> - 1.8.1-2
- Rebuild for new Boost, BZ 590205.

* Tue May 04 2010 Jon Ciesla <limb@jcomserv.net> - 1.8.1-1
- Upstream maintenance release.

* Mon Apr 05 2010 Jon Ciesla <limb@jcomserv.net> - 1.8-1
- New stable.

* Wed Mar 17 2010 Jon Ciesla <limb@jcomserv.net> - 1.7.15-1
- RC1.

* Thu Mar 11 2010 Jon Ciesla <limb@jcomserv.net> - 1.7.14-1
- Beta 7.

* Thu Feb 11 2010 Jon Ciesla <limb@jcomserv.net> - 1.7.13-1
- Beta 6.

* Fri Jan 22 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.7.12-2
- Rebuild for Boost soname bump
- Fix mixed space and tabs
- Fix def attr

* Tue Jan 19 2010 Jon Ciesla <limb@jcomserv.net> - 1.7.12-1
- Beta 5.

* Mon Jan 04 2010 Jon Ciesla <limb@jcomserv.net> - 1.7.11-1
- Beta 4.

* Tue Dec 15 2009 Jon Ciesla <limb@jcomserv.net> - 1.7.10-1
- Beta 3.

* Tue Dec 01 2009 Jon Ciesla <limb@jcomserv.net> - 1.7.9-1
- Beta.
- Add lua-devel BR, altered autoreconf options.
- Dropped fribidi patch, upstreamed.

* Sun Sep 06 2009 Warren Togami <wtogami@redhat.com> - 1.6.5-1
- 1.6.5

* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

* Fri Jul 10 2009 Jon Ciesla <limb@jcomserv.net> - 1.6.4-2
- Fribidi patch, BZ 504526.

* Sun Jul 05 2009 Warren Togami <wtogami@redhat.com> - 1.6.4-1
- 1.6.4 maintenance release

* Sun Jun 28 2009 Warren Togami <wtogami@redhat.com> - 1.6.3-1
- 1.6.3 maintenance release

* Tue May 12 2009 Jon Ciesla <limb@jcomserv.net> - 1.6.2-1
- 1.6.2 maintenance release.

* Tue Apr 21 2009 Debarshi Ray <rishi@fedoraproject.org> - 1.6.1-2
- Respect $RPM_OPT_FLAGS, BZ 496897.

* Mon Apr 20 2009 Jon Ciesla <limb@jcomserv.net> - 1.6.1-1
- 1.6.1 maintenance release.

* Mon Mar 23 2009 Jon Ciesla <limb@jcomserv.net> - 1.6-1
- Update to 1.6 stable.

* Tue Mar 17 2009 Jon Ciesla <limb@jcomserv.net> - 1.5.14-1
- Update to 1.5.14.

* Wed Mar 11 2009 Jon Ciesla <limb@jcomserv.net> - 1.5.13-1
- Update to 1.5.13.

* Wed Mar 04 2009 Jon Ciesla <limb@jcomserv.net> - 1.5.12-1
- Update to 1.5.12.

* Wed Feb 25 2009 Jon Ciesla <limb@jcomserv.net> - 1.5.11-5
- Drop -Werror.

* Wed Feb 25 2009 Jon Ciesla <limb@jcomserv.net> - 1.5.11-4
- Add pango BR.

* Wed Feb 25 2009 Jon Ciesla <limb@jcomserv.net> - 1.5.11-3
- Add SDL_ttf BR.

* Wed Feb 25 2009 Jon Ciesla <limb@jcomserv.net> - 1.5.11-2
- Rename rediffed ogg test patch.

* Wed Feb 25 2009 Jon Ciesla <limb@jcomserv.net> - 1.5.11-1
- Update to dev version 1.5.11.

* Tue Feb 24 2009 Jon Ciesla <limb@jcomserv.net> - 1.5.10-1
- Update to dev version 1.5.10.
- Move data to noarch.

* Wed Feb 04 2009 Jon Ciesla <limb@jcomserv.net> - 1.5.9-1
- Update to dev version 1.5.9.

* Mon Feb 02 2009 Jon Ciesla <limb@jcomserv.net> - 1.5.8-1
- Update to dev version 1.5.8.
- Rediffed remove-ogg-test patch.

* Sun Dec 28 2008 Warren Togami <wtogami@redhat.com> - 1.4.7-1
- 1.4.7
- Remove font requirement

* Wed Dec 17 2008 Benjamin Kosnik  <bkoz@redhat.com> - 1.4.6-6
- Rebuild for boost-1.37.0.

* Sun Dec 14 2008 Warren Togami <wtogami@redhat.com> - 1.4.6-5
- No longer ship Wesnoth's redundant copy of fonts.
  We now symlink to the Fedora packaged fonts that wesnoth expects.
  dejavu-fonts (Latin)
  sazanami-fonts-gothic (Japanese)
  wqy-zenhei-fonts (Chinese)
  We do not explicitly require these fonts.  Normally these fonts would be 
  already installed by your system to use that language.

* Wed Dec 10 2008 Jon Ciesla <limb@jcomserv.net> - 1.4.6-4
- Rediffed fuzzy gcc43 patch.

* Tue Nov 18 2008 Warren Togami <wtogami@redhat.com> 1.4.6-3
- split into -data noarch subpackage to save mirror space

* Mon Nov 17 2008 Jon Ciesla <limb@jcomserv.net> - 1.4.6-1
- New upstream release.

* Tue Sep 09 2008 Jon Ciesla <limb@jcomserv.net> - 1.4.5-1
- New upstream release.

* Tue Aug 12 2008 Jon Ciesla <limb@jcomserv.net> - 1.4.4-1
- New upstream release.
- Introduced patch fuzz workaround, will fix.

* Thu May 08 2008 Jon Ciesla <limb@jcomserv.net> - 1.4.2-1
- New upstream maintenance release.

* Fri Apr 18 2008 Jon Ciesla <limb@jcomserv.net> - 1.4.1-1
- New upstream bugfix release.

* Wed Apr 09 2008 Jon Ciesla <limb@jcomserv.net> - 1.4-2
- LSB initscript fix, BZ 247094.

* Tue Mar 11 2008 Jon Ciesla <limb@jcomserv.net> - 1.4-1
- Update to 1.4 stable.

* Fri Feb 15 2008 Jon Ciesla <limb@jcomserv.net> - 1.3.16-1
- Update to 1.3.16.
- Updated ogg test patch.
- Corrected license tag.
- Added boost-devel BR.
- Corrected .desktop/icon handling for subpackage.

* Mon Feb 11 2008 Warren Togami <wtogami@redhat.com> - 1.2.8-5
- Patch to fix build with gcc-4.3.

* Fri Feb  8 2008 Brian Pepple <bpepple@fedoraproject.org> - 1.2.8-4
- Rebuild for gcc-4.3.

* Fri Nov 30 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.8-3
- Re-add the server-gid that accidently got removed.

* Fri Nov 30 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.8-2
- Add patch to drop ogg test from configure script, until better workaround.
- Enable python support.

* Thu Nov 29 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.8-1
- Update to 1.2.8.

* Tue Oct  9 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.7-1
- Update to 1.2.7. Fixes #324841 (CVE-2007-3917)

* Tue Aug 21 2007 Warren Togami <wtogami@redhat.com> - 1.2.6-2
- rebuild

* Sat Jul 28 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.6-1
- Update to 1.2.6.

* Sat Jun 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.5-2
- Drop wmlxgettext.

* Sat Jun 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.5-1
- Update to 1.2.5.

* Sat Apr 21 2007 Warren Togami <wtogami@redhat.com> - 1.2.4-1
- 1.2.4

* Fri Mar 16 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-1
- Update to 1.2.3.

* Sat Feb 24 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-2
- Bump.

* Sat Feb 24 2007 Warren Togami <wtogami@redhat.com> - 1.2.2-1
- 1.2.2

* Mon Jan 15 2007 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-1
- Update to 1.2.1.

* Sun Dec 24 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.2-1
- Update to 1.2.

* Sat Dec 23 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.1.14-1
- Update to 1.1.14.
- Add BR on fribidi-devel.
- Drop X-Fedora category from desktop file.
- Drop help speedup patch, fixed upstream.
- Drop ttf patch, fixed upstream.

* Thu Sep  7 2006 Brian Pepple <bpepple@fedoraproject.org> - 1.0.2-4
- Rebuild for FC6.
- Remove unnecessary BR on SDL-devel.

* Tue Jul 18 2006 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.0.2-3
- fix #199079, so loading some help pages like the "License" doesn't
  take ages
- remove BR SDL_ttf-devel, an included/patched copy is used since 0.8.7
- patch included SDL_ttf to build with freetype 2.x and not access
  an old freetype 1.x internal

* Wed Feb 15 2006 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.0.2-2
- rebuilt for FC5

* Wed Dec 21 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.0.2-1
- update to 1.0.2

* Sat Oct 22 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.0.1-1
- update to 1.0.1

* Tue Oct  4 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.0-1
- update to 1.0
- remove README.fedora warning about game development status

* Wed Sep 21 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.0-0.1.rc1
- update to 1.0rc1
- remove exe bit from Turkish manual

* Wed Sep 14 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.9.7-1
- update to 0.9.7

* Wed Aug 31 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.9.6-2
- update summary and description
- move and specify server package scriptlet requirements

* Sun Aug 28 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.9.6-1
- update to 0.9.6

* Sat Aug 13 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.9.5-1
- update to 0.9.5

* Wed Jul 27 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.9.4-1
- update to 0.9.4

* Fri Jul  8 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.9.3-1
- update to 0.9.3

* Mon Jun 13 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.9.2-1
- update to 0.9.2
- BR libpng-devel is needed
- add initscript and scriptlets for -server package
- don't build campaign server (upstream suggestion)
- split off editor+tools into -tools sub-package
- install translations into system's locale directories
- merge Panu's changes:
  Sat Apr 16 2005 Panu Matilainen <pmatilai@welho.com> 0.9.0-1
- enable campaign server and tools
- split server to separate package
- add wesnothd user in server %%pre
- buildrequire gettext

* Thu May 26 2005 Jeremy Katz <katzj@redhat.com> - 0.8-5
- fix build on x86_64

* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 0.8-4
- rebuild on all arches

* Fri Apr 08 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
- rebuilt

* Fri Jul 09 2004 Panu Matilainen <pmatilai@welho.com> 0:0.8-0.fdr.2
- use upstream desktop file and icon

* Sat Jul 03 2004 Panu Matilainen <pmatilai@welho.com> 0:0.8-0.fdr.1
- update to 0.8

* Tue Mar 30 2004 Panu Matilainen <pmatilai@welho.com> 0:0.7-0.fdr.1
- update to 0.7

* Wed Dec 17 2003 Panu Matilainen <pmatilai@welho.com> 0:0.6.1-0.fdr.1
- update to 0.6.1

* Mon Dec 15 2003 Panu Matilainen <pmatilai@welho.com> 0:0.6-0.fdr.2
- update to bugfixed tarball of 0.6

* Fri Dec 12 2003 Panu Matilainen <pmatilai@welho.com> 0:0.6-0.fdr.1
- update to 0.6
- adapt to the new autoconf make system
- enable editor and server

* Tue Nov 11 2003 Panu Matilainen <pmatilai@welho.com> 0:0.5.1-0.fdr.1
- update to 0.5.1
- Fedora -> fedora in desktop file vendor

* Tue Nov 04 2003 Panu Matilainen <pmatilai@welho.com> 0:0.5-0.fdr.1
- Initial Fedora packaging.